summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-11 18:07:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-11 18:07:19 +0000
commit19cc4dc12988b78c8bbbaffc7e786f7df386f2dc (patch)
tree69f19f96995f08471b26b914cad2269efd1390d4 /packages/python
parente8bfd5e0314d63e3f9a0fe012d7d8f032ae10fbb (diff)
add python-sword, python bindings for the sword document reader library
patch courtesy Matt Reimer, thanks.
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-sword_1.5.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/python/python-sword_1.5.8.bb b/packages/python/python-sword_1.5.8.bb
new file mode 100644
index 0000000000..ddbebb503a
--- /dev/null
+++ b/packages/python/python-sword_1.5.8.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Matt Reimer <mreimer@vpop.net>"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ ./autogen.sh
+}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}