summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-08-05 10:29:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-08-05 10:29:04 +0000
commit7f055c4ffb2bddec2da28bbf35069ef28396cd5b (patch)
tree982d18a28bbd9305ad9b6c084f8ae82fa769d529 /packages/python
parente9de7a29dfc59a02a854ee89b8e3b1e897a83792 (diff)
python-native 2.3.3 remove
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-native-2.3.3/.mtn2git_empty0
-rw-r--r--packages/python/python-native-2.3.3/bindir-libdir.patch18
-rw-r--r--packages/python/python-native-2.3.3/cross-distutils.patch38
-rw-r--r--packages/python/python-native_2.3.3.bb29
4 files changed, 0 insertions, 85 deletions
diff --git a/packages/python/python-native-2.3.3/.mtn2git_empty b/packages/python/python-native-2.3.3/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/python/python-native-2.3.3/.mtn2git_empty
+++ /dev/null
diff --git a/packages/python/python-native-2.3.3/bindir-libdir.patch b/packages/python/python-native-2.3.3/bindir-libdir.patch
deleted file mode 100644
index 999bddc449..0000000000
--- a/packages/python/python-native-2.3.3/bindir-libdir.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-
-#
-# Made by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- Python-2.3.1/Makefile.pre.in~bindir-libdir 2003-09-20 12:50:28.000000000 +0200
-+++ Python-2.3.1/Makefile.pre.in 2003-11-02 19:53:17.000000000 +0100
-@@ -78,8 +78,8 @@
- exec_prefix= @exec_prefix@
-
- # Expanded directories
--BINDIR= $(exec_prefix)/bin
--LIBDIR= $(exec_prefix)/lib
-+BINDIR= @bindir@
-+LIBDIR= @libdir@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/packages/python/python-native-2.3.3/cross-distutils.patch b/packages/python/python-native-2.3.3/cross-distutils.patch
deleted file mode 100644
index 76ae883c1d..0000000000
--- a/packages/python/python-native-2.3.3/cross-distutils.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- Python-2.3.3/Lib/distutils/sysconfig.py~cross-distutils 2003-02-10 15:02:33.000000000 +0100
-+++ Python-2.3.3/Lib/distutils/sysconfig.py 2004-03-02 20:15:05.000000000 +0100
-@@ -19,8 +19,8 @@
- from errors import DistutilsPlatformError
-
- # These are needed in a couple of spots, so just compute them once.
--PREFIX = os.path.normpath(sys.prefix)
--EXEC_PREFIX = os.path.normpath(sys.exec_prefix)
-+PREFIX = os.path.normpath(sys.prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-+EXEC_PREFIX = os.path.normpath(sys.exec_prefix).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
- # python_build: (Boolean) if true, we're either building Python or
- # building an extension with an un-installed Python, so we use
-@@ -192,7 +192,8 @@
- else:
- # The name of the config.h file changed in 2.2
- config_h = 'pyconfig.h'
-- return os.path.join(inc_dir, config_h)
-+ print "NOTE: sysconfig.get_config_h_filename() altered for OpenEmbedded"
-+ return os.path.join(inc_dir, config_h).replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
-
- def get_makefile_filename():
-@@ -200,7 +201,8 @@
- if python_build:
- return os.path.join(os.path.dirname(sys.executable), "Makefile")
- lib_dir = get_python_lib(plat_specific=1, standard_lib=1)
-- return os.path.join(lib_dir, "config", "Makefile")
-+ print "NOTE: sysconfig.get_config_h_filename() altered for OpenEmbedded"
-+ return os.path.join(lib_dir, "config", "Makefile").replace( os.getenv("BUILD_SYS"), os.getenv("HOST_SYS") )
-
-
- def parse_config_h(fp, g=None):
diff --git a/packages/python/python-native_2.3.3.bb b/packages/python/python-native_2.3.3.bb
deleted file mode 100644
index 8f2e782a7b..0000000000
--- a/packages/python/python-native_2.3.3.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Python Programming Language"
-HOMEPAGE = "http://www.python.org"
-LICENSE = "PSF"
-SECTION = "devel/python"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = ""
-PR = "r1"
-
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://cross-distutils.patch;patch=1"
-S = "${WORKDIR}/Python-${PV}"
-
-inherit autotools native
-
-EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --with-signal-module --with-wctype-functions \
- --with-prefix=${STAGING_DIR} --with-exec-prefix=${STAGING_DIR}/${BUILD_SYS}"
-EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
-
-do_configure () {
- oe_runconf
-}
-
-do_stage_append() {
- # install pgen for later usage with non-native builds
- install Parser/pgen ${STAGING_DIR}/${BUILD_SYS}/bin/
-}
-