summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorNicolas Ferre <nicolasfr@gmail.com>2006-12-03 21:07:10 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2006-12-03 21:07:10 +0000
commit22c9eea35a98e1c2dd2d413f4066e88277b6c1cb (patch)
tree788a9b12dde16eaaf1f3004597b08f9a78d53ddb /packages/python
parent82266fc0cc7692fcb19d86a62e628727fad32257 (diff)
python-pyiw: added 0.3.2 - close #1635
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-pyiw-0.3.2/.mtn2git_empty0
-rw-r--r--packages/python/python-pyiw-0.3.2/Makefile18
-rw-r--r--packages/python/python-pyiw_0.3.2.bb32
3 files changed, 50 insertions, 0 deletions
diff --git a/packages/python/python-pyiw-0.3.2/.mtn2git_empty b/packages/python/python-pyiw-0.3.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pyiw-0.3.2/.mtn2git_empty
diff --git a/packages/python/python-pyiw-0.3.2/Makefile b/packages/python/python-pyiw-0.3.2/Makefile
new file mode 100644
index 0000000000..2ea7baec08
--- /dev/null
+++ b/packages/python/python-pyiw-0.3.2/Makefile
@@ -0,0 +1,18 @@
+# Simple Makfile
+
+NAME = pyiw
+LIBS += -liw
+
+#static: pyiw.c
+# @echo "Statically Building/Linking $(NAME)"
+# @$(CC) $(CFLAGS) -Istaticlibiw $(<) -shared -o $(NAME).so staticlibiw/libiw.a
+
+dynamic: pyiw.c
+ @echo "Dynamically Building/Linking $(NAME)"
+ @$(CC) $(CFLAGS) $(LDFLAGS) $(LIBS) $(<) -shared -o $(NAME).so
+
+clean:
+ @rm -rf *.o
+ @rm -rf $(NAME).so
+ @rm -rf $(NAME).so.t*
+
diff --git a/packages/python/python-pyiw_0.3.2.bb b/packages/python/python-pyiw_0.3.2.bb
new file mode 100644
index 0000000000..aa86a07e8f
--- /dev/null
+++ b/packages/python/python-pyiw_0.3.2.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "PyIW is a simple Python extension module written in C \
+that interfaces with libiw and provides a very 'pythonic' API to programmers."
+HOMEPAGE = "http://www.emperorlinux.com/etc/contrib/?page=pyiw"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "wireless-tools"
+RDEPENDS = "python-core libiw"
+PR = "ml0"
+
+SRC_URI = "http://downloads.emperorlinux.com/contrib/pyiw/pyiw-${PV}.tbz2 \
+ file://Makefile"
+
+S="${WORKDIR}/pyiw-${PV}"
+
+do_unpack_real () {
+ tar jxvf pyiw-${PV}.tbz2
+ cp Makefile pyiw-${PV}/
+}
+do_unpack_real[dirs] = "${WORKDIR}"
+addtask unpack_real before do_patch after do_unpack
+
+inherit autotools pkgconfig distutils-base
+
+CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR}"
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
+ install -m 0755 pyiw.so ${D}${libdir}/${PYTHON_DIR}/site-packages/pyiw.so
+}
+
+FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/pyiw.so"