summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-02-09 17:07:59 +0100
committerKoen Kooi <koen@openembedded.org>2009-02-09 17:07:59 +0100
commitd768e61faa9f59ea5fdd9c51b8e23d8dd53c2263 (patch)
tree498185477f059501a25a36324d983cad2e0bf51a /packages/python
parent0d09acc3587baf6981b4f787b021499eeb5f4a6e (diff)
python 2.6.1: add softft fix from libffi, this hopefully makes python-ctypes work on ARMs with fpu and softfp
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python_2.6.1.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages/python/python_2.6.1.bb b/packages/python/python_2.6.1.bb
index 8c3f3544a8..ae9f8ee725 100644
--- a/packages/python/python_2.6.1.bb
+++ b/packages/python/python_2.6.1.bb
@@ -1,7 +1,7 @@
require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "ml2"
+PR = "ml3"
SRC_URI = "\
http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
@@ -27,6 +27,11 @@ S = "${WORKDIR}/Python-${PV}"
inherit autotools
+# The 3 lines below are copied from the libffi recipe, ctypes ships its own copy of the libffi sources
+#Somehow gcc doesn't set __SOFTFP__ when passing -mfloatabi=softp :(
+TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
+TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
+
#
# copy config.h and an appropriate Makefile for distutils.sysconfig
# which laters uses the information out of these to compile extensions