summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-13 00:03:10 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-15 21:31:31 +0100
commitc9a66752f513da38eeaa792a892de9b5c596eb46 (patch)
tree1e2a13dadebb1328a291ea1ad5a4113002e560fd /packages/python
parent56fc6cc7487e9329027a62f22d6e64a9bc5a25a0 (diff)
python-twisted 2.5.0: improve packaging (still not 100% ok though)
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-twisted_2.5.0.bb198
1 files changed, 106 insertions, 92 deletions
diff --git a/packages/python/python-twisted_2.5.0.bb b/packages/python/python-twisted_2.5.0.bb
index ccd3e26101..ef5a98e2b8 100644
--- a/packages/python/python-twisted_2.5.0.bb
+++ b/packages/python/python-twisted_2.5.0.bb
@@ -5,61 +5,74 @@ HOMEPAGE = "http://www.twistedmatrix.com"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "LGPL"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-${PV}.tar.bz2 \
file://remove-zope-check.patch;patch=1"
-
S = "${WORKDIR}/Twisted-${PV}"
inherit distutils
-PACKAGES += "python-twisted-zsh python-twisted-test python-twisted-protocols \
- python-twisted-runner-dbg \
- python-twisted-bin python-twisted-conch python-twisted-lore \
- python-twisted-mail python-twisted-names python-twisted-news python-twisted-runner \
- python-twisted-web python-twisted-words python-twisted python-twisted-core \
- "
-
-RDEPENDS = "python-core python-zopeinterface"
-RDEPENDS_python-twisted += "python-twisted-bin python-twisted-conch python-twisted-core \
- python-twisted-lore python-twisted-mail python-twisted-names \
- python-twisted-news python-twisted-runner python-twisted-web \
- python-twisted-words"
+PACKAGES += "\
+ ${PN}-zsh \
+ ${PN}-test \
+ ${PN}-protocols \
+ ${PN}-bin \
+ ${PN}-conch \
+ ${PN}-lore \
+ ${PN}-mail \
+ ${PN}-names \
+ ${PN}-news \
+ ${PN}-runner \
+ ${PN}-web \
+ ${PN}-words \
+ ${PN}-core \
+"
+RDEPENDS = "python-core python-zopeinterface"
+RDEPENDS_${PN} += "\
+ ${PN}-bin \
+ ${PN}-conch \
+ ${PN}-lore \
+ ${PN}-mail \
+ ${PN}-names \
+ ${PN}-news \
+ ${PN}-runner \
+ ${PN}-web \
+ ${PN}-words \
+"
ALLOW_EMPTY = "1"
FILES_${PN} = ""
-FILES_python-twisted = ""
-FILES_python-twisted-test = " \
- ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/web/test \
+FILES_${PN}-test = " \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
"
-FILES_python-twisted-protocols = " \
+FILES_${PN}-protocols = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/ \
"
-FILES_python-twisted-zsh = " \
+FILES_${PN}-zsh = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
"
-FILES_python-twisted-bin = " \
+FILES_${PN}-bin = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \
${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \
"
-FILES_python-twisted-conch = " \
+FILES_${PN}-conch = " \
${bindir}/ckeygen \
${bindir}/tkconch \
${bindir}/conch \
${bindir}/conchftp \
- ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/conch \
"
-FILES_python-twisted-core = " \
+FILES_${PN}-core = " \
${bindir}/manhole \
${bindir}/mktap \
${bindir}/twistd \
@@ -68,17 +81,17 @@ ${bindir}/tap2rpm \
${bindir}/tapconvert \
${bindir}/tkmktap \
${bindir}/trial \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
@@ -89,95 +102,96 @@ ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugin.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugin.py* \
"
-FILES_python-twisted-lore = " \
+FILES_${PN}-lore = " \
${bindir}/bookify \
${bindir}/lore \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \
"
-FILES_python-twisted-mail = " \
+FILES_${PN}-mail = " \
${bindir}/mailmail \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
"
-FILES_python-twisted-names = " \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py \
+FILES_${PN}-names = " \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
"
-FILES_python-twisted-news = " \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py \
+FILES_${PN}-news = " \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
"
-FILES_python-twisted-runner = " \
+FILES_${PN}-runner = " \
${libdir}/site-packages/twisted/runner/portmap.so \
${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
"
-FILES_python-twisted-web = " \
+FILES_${PN}-web = " \
${bindir}/websetroot \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
"
-FILES_python-twisted-words = " \
+FILES_${PN}-words = " \
${bindir}/im \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
"
-FILES_python-twisted-runner-dbg += " \
-${libdir}/${PYTHON_DIR}/site-packages/twisted/runner/.debug"
-
+FILES_${PN}-dbg += " \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
+${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
+"