summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-25 13:28:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-25 13:28:38 +0000
commit77dede6a85eb8aef312802c3029c27b7f5bf0720 (patch)
treed5408a49b21f1dff8b1e2935df9ddbfb547fa96c /packages/python
parentc25b1b3efea1ed12c1953978b7a083f666dc4e68 (diff)
python: add patch to fix Tcl/Tk detection. python-core now correctly emits
python-tkinter including lib-dynload/_tkinter.so
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.4.1-manifest.inc6
-rw-r--r--packages/python/python-2.4.1/fix-tkinter-detection.patch39
-rw-r--r--packages/python/python_2.4.1.bb9
3 files changed, 47 insertions, 7 deletions
diff --git a/packages/python/python-2.4.1-manifest.inc b/packages/python/python-2.4.1-manifest.inc
index 586a525cda..a18eb4e4eb 100644
--- a/packages/python/python-2.4.1-manifest.inc
+++ b/packages/python/python-2.4.1-manifest.inc
@@ -1,5 +1,5 @@
########################################################################################################################
-### AUTO-GENERATED by './generate-oe.py' [(C) 2002-2005 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Fri Jul 1 18:03:30 2005
+### AUTO-GENERATED by './generate-oe.py' [(C) 2002-2005 Michael 'Mickey' Lauer <mickey@Vanille.de>] on Sun Sep 25 15:27:47 2005
###
### Visit THE Python for Embedded Systems Site => http://www.Vanille.de/projects/python.spy
###
@@ -111,9 +111,9 @@ RDEPENDS_python-unixadmin="python-core"
FILES_python-unixadmin="${libdir}/python2.4/lib-dynload/nis.so ${libdir}/python2.4/lib-dynload/grp.so ${libdir}/python2.4/lib-dynload/pwd.so ${libdir}/python2.4/getpass.* "
DESCRIPTION_python-tkinter="Python Tcl/Tk Bindings"
-PR_python-tkinter="ml3"
+PR_python-tkinter="ml4"
RDEPENDS_python-tkinter="python-core"
-FILES_python-tkinter="${libdir}/python2.4/lib-tk "
+FILES_python-tkinter="${libdir}/python2.4/lib-dynload/_tkinter.so ${libdir}/python2.4/lib-tk "
DESCRIPTION_python-gdbm="Python GNU Database Support"
PR_python-gdbm="ml3"
diff --git a/packages/python/python-2.4.1/fix-tkinter-detection.patch b/packages/python/python-2.4.1/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..602aa8e021
--- /dev/null
+++ b/packages/python/python-2.4.1/fix-tkinter-detection.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Python-2.4.1/setup.py~fix-tkinter-detection
++++ Python-2.4.1/setup.py
+@@ -999,7 +999,7 @@
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1018,22 +1018,6 @@
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)
diff --git a/packages/python/python_2.4.1.bb b/packages/python/python_2.4.1.bb
index 09febc9274..43cb187aef 100644
--- a/packages/python/python_2.4.1.bb
+++ b/packages/python/python_2.4.1.bb
@@ -5,14 +5,15 @@ SECTION = "devel/python"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
PROVIDES = "python python-core"
-DEPENDS = "python-native readline zlib gdbm openssl"
-PR = "ml7"
+DEPENDS = "python-native readline zlib gdbm openssl tcl tk"
+PR = "ml8"
PYTHON_MAJMIN = "2.4"
SRC_URI = "ftp://www.python.org/pub/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://crosscompile.patch;patch=1"
+ file://bindir-libdir.patch;patch=1 \
+ file://crosscompile.patch;patch=1 \
+ file://fix-tkinter-detection.patch;patch=1"
S = "${WORKDIR}/Python-${PV}"
inherit autotools