summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-06 22:37:08 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-06 22:37:08 +0000
commit182065fd7d66b9eb9480913c99f39428ef657c9a (patch)
treef1841ad3dc0b911784c7a6507342de3d2bd12d8e /packages/python
parent8f29644efce44f9059fb290b644047caf9146c1b (diff)
python 2.5.1 sitecustomize.py now saves the history in $HOME, not in /tmp
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5.1/sitecustomize.py6
-rw-r--r--packages/python/python_2.5.1.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/packages/python/python-2.5.1/sitecustomize.py b/packages/python/python-2.5.1/sitecustomize.py
index b5e78d3200..4c0ba3f0da 100644
--- a/packages/python/python-2.5.1/sitecustomize.py
+++ b/packages/python/python-2.5.1/sitecustomize.py
@@ -7,11 +7,11 @@
# * load command line history on startup
# * save command line history on exit
-HISTORY_FILENAME = "/tmp/python-history-file.txt"
+import os
def __exithandler():
try:
- readline.write_history_file( HISTORY_FILENAME )
+ readline.write_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
except IOError:
pass
@@ -22,7 +22,7 @@ def __registerExitHandler():
def __enableReadlineSupport():
readline.parse_and_bind("tab: complete")
try:
- readline.read_history_file( "/tmp/python-history-file.txt" )
+ readline.read_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
except IOError:
pass
diff --git a/packages/python/python_2.5.1.bb b/packages/python/python_2.5.1.bb
index b274b0d7f9..668c2a7833 100644
--- a/packages/python/python_2.5.1.bb
+++ b/packages/python/python_2.5.1.bb
@@ -7,7 +7,7 @@ DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
# NOTE: Keep the digit in sync with BASEREV in contrib/generate-manifest-2.5.py
-PR = "ml7"
+PR = "ml8"
PYTHON_MAJMIN = "2.5"