summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 11:15:22 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 11:15:22 +0000
commit0c25fa3e7098c3847f4fc3eb042b94d0e142b9b3 (patch)
treed6a2d08a45a861da7f89edffa9894df673807cba /packages/python
parent1d90efcdbf94571236a9d770af3d1adfb8ced770 (diff)
disapproval of revision '38e2cd40a04ac88008e433a43002415c562145e4'
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-dbus/python-path.patch21
-rw-r--r--packages/python/python-dbus_0.81.1.bb8
-rw-r--r--packages/python/python-pygobject-native_2.12.2.bb3
-rw-r--r--packages/python/python-pygobject_2.12.2.bb23
4 files changed, 28 insertions, 27 deletions
diff --git a/packages/python/python-dbus/python-path.patch b/packages/python/python-dbus/python-path.patch
deleted file mode 100644
index 6bdbd19d03..0000000000
--- a/packages/python/python-dbus/python-path.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- dbus-python-0.81.1/m4.orig/am-check-python-headers.m4
-+++ dbus-python-0.81.1/m4/am-check-python-headers.m4
-@@ -7214,12 +7214,18 @@
- [AC_REQUIRE([AM_PATH_PYTHON])
- AC_MSG_CHECKING(for headers required to compile python extensions)
- dnl deduce PYTHON_INCLUDES
-+AC_ARG_WITH(python-includes,
-+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
-+if test x$py_exec_prefix != x; then
-+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
-+else
- py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
- py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
- PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
- if test "$py_prefix" != "$py_exec_prefix"; then
- PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
- fi
-+fi
- AC_SUBST(PYTHON_INCLUDES)
- dnl check if the headers exist:
- save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-dbus_0.81.1.bb b/packages/python/python-dbus_0.81.1.bb
index ad3b1c177b..82b9c390ca 100644
--- a/packages/python/python-dbus_0.81.1.bb
+++ b/packages/python/python-dbus_0.81.1.bb
@@ -4,15 +4,11 @@ HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
-PR = "ml1"
+PR = "ml0"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
- file://allow-older-autotools.patch;patch=1 \
- file://python-path.patch;patch=1"
-
+ file://allow-older-autotools.patch;patch=1"
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools
-EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
-
diff --git a/packages/python/python-pygobject-native_2.12.2.bb b/packages/python/python-pygobject-native_2.12.2.bb
new file mode 100644
index 0000000000..c93950b31b
--- /dev/null
+++ b/packages/python/python-pygobject-native_2.12.2.bb
@@ -0,0 +1,3 @@
+require python-pygobject_${PV}.bb
+
+DEPENDS = "python-native"
diff --git a/packages/python/python-pygobject_2.12.2.bb b/packages/python/python-pygobject_2.12.2.bb
new file mode 100644
index 0000000000..1604b54715
--- /dev/null
+++ b/packages/python/python-pygobject_2.12.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "python-pygobject-native"
+PR = "ml2"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-${PV}.tar.bz2"
+S = "${WORKDIR}/pygobject-${PV}"
+
+inherit autotools distutils-base pkgconfig
+
+# otherwise the main package keeps snatching the .pc file away
+# and therefore depends on glib-2.0-dev (which only the -dev
+# package should).
+PACKAGES =+ "${PN}-dev"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}/../share/pygobject/
+ cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
+ install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+ cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+}