summaryrefslogtreecommitdiff
path: root/packages/python/python_2.3.4.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-06-11 15:56:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-11 15:56:52 +0000
commit07f796a9dde275d91e980cc6fe5c4fd98b005bae (patch)
tree433a69380c7699bdb4670a920d4998027107a248 /packages/python/python_2.3.4.bb
parent8cf158998c571ae013d39b9aac3dfbc2ff61a57e (diff)
python: remove 2.3.4
Diffstat (limited to 'packages/python/python_2.3.4.bb')
-rw-r--r--packages/python/python_2.3.4.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/packages/python/python_2.3.4.bb b/packages/python/python_2.3.4.bb
deleted file mode 100644
index e6da09e48f..0000000000
--- a/packages/python/python_2.3.4.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-DESCRIPTION = "Python Programming Language"
-HOMEPAGE = "http://www.python.org"
-LICENSE = "PSF"
-SECTION = "devel/python"
-PRIORITY = "optional"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-DEPENDS = "python-native zlib gdbm"
-PR = "ml5"
-
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://crosscompile.patch;patch=1"
-S = "${WORKDIR}/Python-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc --without-cxx --with-signal-module --with-wctype-functions"
-
-#
-# copy config.h and an appropriate Makefile for distutils.sysconfig
-# which laters uses the information out of these to compile extensions
-#
-do_compile_prepend() {
- install -d ${STAGING_INCDIR}/python2.3/
- install -d ${STAGING_LIBDIR}/python2.3/config/
- install -m 0644 pyconfig.h ${STAGING_INCDIR}/python2.3/
- install -m 0644 Makefile Makefile.orig
- install -m 0644 Makefile Makefile.backup
- sed -e 's,${includedir},${STAGING_INCDIR},' < Makefile.backup > Makefile
- install -m 0644 Makefile Makefile.backup
- sed -e 's,${libdir},${STAGING_LIBDIR},' < Makefile.backup > Makefile
- install -m 0644 Makefile ${STAGING_LIBDIR}/python2.3/config/
-}
-
-do_compile() {
- oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
- HOSTPYTHON=${STAGING_BINDIR}/python \
- STAGING_LIBDIR=${STAGING_LIBDIR} \
- STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
-}
-
-do_stage() {
- install -m 0644 Include/*.h ${STAGING_INCDIR}/python2.3/
-}
-
-do_install() {
- install -m 0644 Makefile.orig Makefile
- oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
- HOSTPYTHON=${STAGING_BINDIR}/python \
- STAGING_LIBDIR=${STAGING_LIBDIR} \
- STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- DESTDIR=${D} install
-}
-
-include python-${PV}-manifest.inc
-RPROVIDES_python-core = "python"