summaryrefslogtreecommitdiff
path: root/packages/python/python24-sip_4.1.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-16 08:40:59 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-16 08:40:59 +0000
commit94317634ab575b7deae469f83038f770e35fb737 (patch)
treeedf8d1faa64a8b4d689fb916b6eebfc05ceec431 /packages/python/python24-sip_4.1.1.bb
parent93e05f24e5829efd41e6b332c47ceba33980aadd (diff)
python-pyqt: promote qt4 to being the default, rename other packages accordingly
Diffstat (limited to 'packages/python/python24-sip_4.1.1.bb')
-rw-r--r--packages/python/python24-sip_4.1.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/python/python24-sip_4.1.1.bb b/packages/python/python24-sip_4.1.1.bb
new file mode 100644
index 0000000000..8e118ea7de
--- /dev/null
+++ b/packages/python/python24-sip_4.1.1.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Runtime helper for sip-generated python wrapper libraries"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "virtual/libqte2 python"
+RDEPENDS = "python-core"
+PR = "ml4"
+
+SRC_URI = "http://www.vanille.de/mirror/sip-${PV}.tar.gz"
+S = "${WORKDIR}/sip-${PV}/siplib"
+
+inherit palmtop distutils-base
+
+EXTRA_QMAKEVARS_POST += "TEMPLATE=lib \
+ DESTDIR= \
+ VERSION=1.0.0 \
+ TARGET=sip \
+ DEFINES=SIP_QT_SUPPORT \
+ INCLUDEPATH+=. \
+ INCLUDEPATH+=${STAGING_INCDIR}/${PYTHON_DIR} \
+ INCLUDEPATH+=${STAGING_INCDIR}"
+
+do_configure_prepend() {
+ cat siplib.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > siplib.pro
+}
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/
+ oe_libinstall -so libsip ${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/
+ install -m 0644 sip.h ${STAGING_INCDIR}/sip.h
+}
+
+do_install() {
+ install -d ${D}${libdir}/${PYTHON_DIR}/site-packages/
+ install libsip.so.1.0.0 ${D}${libdir}/${PYTHON_DIR}/site-packages/sip.so
+}
+
+FILES_${PN} = "${libdir}/${PYTHON_DIR}/site-packages/sip.so"
+