summaryrefslogtreecommitdiff
path: root/packages/python/python-sword_1.5.10.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-12-04 16:12:15 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-12-04 16:12:15 +0000
commitb573e7d721a912da9aeffe0c3f4a5eef247902a0 (patch)
tree0d1999a13b4a268d36331f26c60cd67fe0f985ce /packages/python/python-sword_1.5.10.bb
parent0e1b13178e3e34ea10411740556dd67c81681b43 (diff)
add python-sword 1.5.10, remove older versions that no longer build. closes #2790
Diffstat (limited to 'packages/python/python-sword_1.5.10.bb')
-rw-r--r--packages/python/python-sword_1.5.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/python/python-sword_1.5.10.bb b/packages/python/python-sword_1.5.10.bb
new file mode 100644
index 0000000000..a18cf89466
--- /dev/null
+++ b/packages/python/python-sword_1.5.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ touch ltmain.sh
+ ./autogen.sh
+}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}