summaryrefslogtreecommitdiff
path: root/packages/python/python-sword_1.5.10.bb
diff options
context:
space:
mode:
authorDaniel Willmann <daniel@totalueberwachung.de>2007-12-13 15:28:42 +0000
committerDaniel Willmann <daniel@totalueberwachung.de>2007-12-13 15:28:42 +0000
commitfe379ffc9b1b75ba62a68f5bc21b854e5da49259 (patch)
tree312e1b5003b9ef65e718b145052d447f2f8e2653 /packages/python/python-sword_1.5.10.bb
parent8a2fba6940e3e07bc7613a431c99a6b7ed433588 (diff)
parentf4a7dac492fabd4f30dcad003cdcabdf6684e39e (diff)
merge of 'ad95f08d419bba954eab21c0d4ef155b70f86dbc'
and 'eeb3a83ad8d45d4069e1ae9170eb852a6bb31d43'
Diffstat (limited to 'packages/python/python-sword_1.5.10.bb')
-rw-r--r--packages/python/python-sword_1.5.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/packages/python/python-sword_1.5.10.bb b/packages/python/python-sword_1.5.10.bb
new file mode 100644
index 0000000000..a18cf89466
--- /dev/null
+++ b/packages/python/python-sword_1.5.10.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Python bindings for the sword library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-core sword"
+DEPENDS = "sword-${PV} swig-native"
+SRCNAME = "sword"
+PR = "r0"
+
+SRC_URI = "http://crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}/bindings/swig/package"
+
+EXTRA_OECONF = "--with-sword-dir=${STAGING_DIR}/${HOST_SYS}"
+
+inherit distutils autotools
+
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ touch ltmain.sh
+ ./autogen.sh
+}
+
+do_compile() {
+ oe_runmake BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} pythonswig python_make
+}
+
+do_install() {
+ cd ${S}/python
+ distutils_do_install
+}