summaryrefslogtreecommitdiff
path: root/packages/python/python-setuptools_0.6c5.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-06-21 08:49:48 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-06-21 08:49:48 +0000
commit7ebefcff1fdc6993a30d1d6789a90c54578068e4 (patch)
tree7f656e7b251105ed59088873071928d4fb1737ba /packages/python/python-setuptools_0.6c5.bb
parent11cd48c28ef8e701fc43b9905a3a4f7af4fb5c8f (diff)
parent35673b07fcb65e7109ed0430a9a4aa7e4313d437 (diff)
merge of '2b710e1818e35c1ae6f03e19452a17638f3b8048'
and '9a039e377450d290fde23e8f83821bd022343fd4'
Diffstat (limited to 'packages/python/python-setuptools_0.6c5.bb')
-rw-r--r--packages/python/python-setuptools_0.6c5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/python/python-setuptools_0.6c5.bb b/packages/python/python-setuptools_0.6c5.bb
new file mode 100644
index 0000000000..0ee3a02229
--- /dev/null
+++ b/packages/python/python-setuptools_0.6c5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT-like"
+RDEPENDS = "python-core python-zlib"
+SRCNAME = "setuptools"
+PR = "r0"
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install
+}
+
+# Deal with .pth file error
+export PYTHONPATH="${D}/${libdir}/${PYTHON_DIR}/site-packages"
+