summaryrefslogtreecommitdiff
path: root/packages/python/python-setuptools_0.6c5.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-06-21 04:38:59 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-06-21 04:38:59 +0000
commit50a2debf442776e1a584cb8828adf56b67124c14 (patch)
tree03f10b50678342748a9fa94ef29a04e09600ab2b /packages/python/python-setuptools_0.6c5.bb
parentfc4a6fd8cc16a9fb13390d107282d43f4b6efc4d (diff)
add python-setuptools. closes #2459
Diffstat (limited to 'packages/python/python-setuptools_0.6c5.bb')
-rw-r--r--packages/python/python-setuptools_0.6c5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/python/python-setuptools_0.6c5.bb b/packages/python/python-setuptools_0.6c5.bb
new file mode 100644
index 0000000000..0ee3a02229
--- /dev/null
+++ b/packages/python/python-setuptools_0.6c5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT-like"
+RDEPENDS = "python-core python-zlib"
+SRCNAME = "setuptools"
+PR = "r0"
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR_NATIVE}/python setup.py install
+}
+
+# Deal with .pth file error
+export PYTHONPATH="${D}/${libdir}/${PYTHON_DIR}/site-packages"
+