summaryrefslogtreecommitdiff
path: root/packages/python/python-scapy_0.9.17.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
commit6579e8daf68dd520b702412208bfeae85af6fadc (patch)
treeef2cfbfe3353bd39e28145995db1287bd2518b8d /packages/python/python-scapy_0.9.17.bb
parentc6c085bf81bd4997bdb216e958d366ddf46438ad (diff)
make python 2.4 as default, move python-sip into python/, make sip4 as default
BKrev: 4208ff7b-sgl7QbT_1xhYPmdi-Oy4g
Diffstat (limited to 'packages/python/python-scapy_0.9.17.bb')
-rw-r--r--packages/python/python-scapy_0.9.17.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/python/python-scapy_0.9.17.bb b/packages/python/python-scapy_0.9.17.bb
index e69de29bb2..3a42abe794 100644
--- a/packages/python/python-scapy_0.9.17.bb
+++ b/packages/python/python-scapy_0.9.17.bb
@@ -0,0 +1,21 @@
+LICENSE = GPL
+DESCRIPTION = "Scapy is a powerful interactive packet manipulation tool, \
+packet generator, network scanner, network discovery, packet sniffer, etc. \
+It can for the moment replace hping, 85% of nmap, arpspoof, arp-sk, arping, \
+tcpdump, tethereal, p0f, ...."
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+RDEPENDS = "python-core python-netclient python-netserver"
+SRCNAME = "scapy"
+
+SRC_URI = "http://www.cartel-securite.fr/pbiondi/python/scapy-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+do_install() {
+ install -d ${D}/${libdir}/python2.3
+ install -m 0755 ${S}/scapy.py ${D}/${libdir}/python2.3/
+}
+
+FILES_${PN} = "${libdir}/python2.3/"
+