summaryrefslogtreecommitdiff
path: root/packages/python/python-quicklauncher_0.0.1.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 22:27:41 +0000
commit9c9c7139952b06112d99b5b11bfa3d36435a6459 (patch)
treefd0778f2b3d3d14f05cd4ff4b4cb341573e92d82 /packages/python/python-quicklauncher_0.0.1.bb
parentf73398ac656a31e2bbd214a3b2c3dc92eddaaecf (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/31 14:27:40-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 14:27:30-08:00 (none)!ggilbert Add many licenses 2004/12/31 21:28:22+00:00 nexus.co.uk!pb fix typo introduced with recent LICENSE patches 2004/12/31 21:12:38+00:00 nexus.co.uk!pb gpe-soundbite is GPL 2004/12/31 21:11:57+00:00 nexus.co.uk!pb gpe-question is GPL 2004/12/31 21:11:12+00:00 nexus.co.uk!pb gpe-nmf is GPL 2004/12/31 21:10:28+00:00 nexus.co.uk!pb gpe-gallery is GPL 2004/12/31 21:09:42+00:00 nexus.co.uk!pb gpe-edit is GPL 2004/12/31 21:07:12+00:00 nexus.co.uk!pb gpe-ownerinfo is GPL 2004/12/31 21:03:44+00:00 nexus.co.uk!pb delete old gpe-bootsplash with no LICENSE 2004/12/31 21:02:29+00:00 nexus.co.uk!pb delete some old gpe-clock versions with no LICENSE 2004/12/31 21:00:16+00:00 nexus.co.uk!pb delete old hotplug-dbus versions with no LICENSE 2004/12/31 20:59:20+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2004/12/31 13:35:00-08:00 (none)!ggilbert Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into olddog.(none):/home/ggilbert/oe/openembedded 2004/12/31 13:34:19-08:00 (none)!ggilbert More licenses 2004/12/31 20:59:03+00:00 nexus.co.uk!pb add LICENSE for gpe-confd, and blow away some old versions BKrev: 41d5d25dQOnhk1FZOyFZXNL3fxoihA
Diffstat (limited to 'packages/python/python-quicklauncher_0.0.1.bb')
-rw-r--r--packages/python/python-quicklauncher_0.0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/python/python-quicklauncher_0.0.1.bb b/packages/python/python-quicklauncher_0.0.1.bb
index e69de29bb2..b3b8139448 100644
--- a/packages/python/python-quicklauncher_0.0.1.bb
+++ b/packages/python/python-quicklauncher_0.0.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A PyQt-optimized Python Quicklauncher for Qt/Embedded based Palmtop Environments"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+RDEPENDS = "python-pyqt"
+PR = "ml1"
+SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/tools/pyquicklauncher"
+S = "${WORKDIR}/pyquicklauncher"
+LICENSE = "GPL"
+inherit distutils
+
+do_compile() {
+ true
+}
+
+#
+# FIXME: Launch during postinstall
+#
+
+do_install() {
+ install -d ${D}/${libdir}/python2.3/
+ install -m 0755 quicklauncher.py ${D}/${libdir}/python2.3/
+ install -d ${D}/${libdir}/python2.3/site-packages/quicklauncher/
+ install -m 0755 testapp.py ${D}/${libdir}/python2.3/site-packages/quicklauncher/
+}
+
+