summaryrefslogtreecommitdiff
path: root/packages/python/python-pysqlite
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-22 13:33:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-22 13:33:57 +0000
commit5cf486256cd4e1e7c54ed6c1ca3caf377d60b8c6 (patch)
tree4745971d355aa22813ec818d936f75629b8fdecd /packages/python/python-pysqlite
parent8a8b7320877bd490d0c598a8b157a603451d916b (diff)
python-pysqlite1: don't let it use host includes
Diffstat (limited to 'packages/python/python-pysqlite')
-rw-r--r--packages/python/python-pysqlite/.mtn2git_empty0
-rw-r--r--packages/python/python-pysqlite/no-host-includes.patch40
2 files changed, 40 insertions, 0 deletions
diff --git a/packages/python/python-pysqlite/.mtn2git_empty b/packages/python/python-pysqlite/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pysqlite/.mtn2git_empty
diff --git a/packages/python/python-pysqlite/no-host-includes.patch b/packages/python/python-pysqlite/no-host-includes.patch
new file mode 100644
index 0000000000..20f5c98402
--- /dev/null
+++ b/packages/python/python-pysqlite/no-host-includes.patch
@@ -0,0 +1,40 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- pysqlite/setup.py~no-host-includes
++++ pysqlite/setup.py
+@@ -11,8 +11,8 @@
+ macros = []
+
+ if sys.platform in ("linux-i386", "linux2"): # most Linux
+- include_dirs = ['/usr/include/sqlite']
+- library_dirs = ['/usr/lib/']
++ include_dirs = []
++ library_dirs = []
+ libraries = [sqlite]
+ runtime_library_dirs = []
+ extra_objects = []
+@@ -21,8 +21,8 @@
+ LOCALBASE = os.environ.get("LOCALBASE", "/opt/local")
+ else:
+ LOCALBASE = os.environ.get("LOCALBASE", "/usr/local")
+- include_dirs = ['%s/include' % LOCALBASE]
+- library_dirs = ['%s/lib/' % LOCALBASE]
++ include_dirs = []
++ library_dirs = []
+ libraries = [sqlite]
+ runtime_library_dirs = []
+ extra_objects = []
+@@ -33,8 +33,8 @@
+ runtime_library_dirs = []
+ extra_objects = []
+ elif os.name == "posix": # most Unixish platforms
+- include_dirs = ['/usr/local/include']
+- library_dirs = ['/usr/local/lib']
++ include_dirs = []
++ library_dirs = []
+ libraries = [sqlite]
+ # On some platorms, this can be used to find the shared libraries
+ # at runtime, if they are in a non-standard location. Doesn't