summaryrefslogtreecommitdiff
path: root/packages/python/python-pyqt_4.3.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-19 12:13:14 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-19 12:13:14 +0000
commit97f96962e8c3e621dbc15936ab8cbcc2a8c84a33 (patch)
tree5e375ce3b9d067809b0a54a91febf4dcf70a2c72 /packages/python/python-pyqt_4.3.bb
parent6c6ccd4ae6c5c0347bef1f78ecb4699bf1b95350 (diff)
python-pyqt: set BROKEN and give some hints where to look to fix
Diffstat (limited to 'packages/python/python-pyqt_4.3.bb')
-rw-r--r--packages/python/python-pyqt_4.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/python/python-pyqt_4.3.bb b/packages/python/python-pyqt_4.3.bb
index aeb7cd9212..98b86c12c3 100644
--- a/packages/python/python-pyqt_4.3.bb
+++ b/packages/python/python-pyqt_4.3.bb
@@ -10,6 +10,22 @@ PR = "ml0"
SRC_URI = "http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/PyQt-x11-gpl-${PV}.tar.gz \
file://cross-compile.patch;patch=1"
+
+BROKEN = "1"
+# Something really fishy wrt. to arm/mips/etc. double vs. qreal. May even be a problem in Qt headers itself.
+# Symptons:
+#| sipQtCoreQTimeLine.cpp:136: error: conflicting return type specified for 'virtual double sipQTimeLine::valueForTime(int) const'
+#| /home/pkg/oe/fic-gta01/tmp/staging/arm-angstrom-linux-gnueabi/qt4/include/QtCore/qtimeline.h:92: error: overriding 'virtual qreal QTimeLine::valueForTime(int) const'
+# And:
+# | sipQtCoreQRectF.cpp: In function 'PyObject* meth_QRectF_getRect(PyObject*, PyObject*)':
+| sipQtCoreQRectF.cpp:1182: error: no matching function for call to 'QRectF::getRect(double*, double*, double*, double*)'
+| /home/pkg/oe/fic-gta01/tmp/staging/arm-angstrom-linux-gnueabi/qt4/include/QtCore/qrect.h:725: note: candidates are: void QRectF::getRect(qreal*, qreal*, qreal*, qreal*) const
+| sipQtCoreQRectF.cpp: In function 'PyObject* meth_QRectF_getCoords(PyObject*, PyObject*)':
+| sipQtCoreQRectF.cpp:1237: error: no matching function for call to 'QRectF::getCoords(double*, double*, double*, double*)'
+| /home/pkg/oe/fic-gta01/tmp/staging/arm-angstrom-linux-gnueabi/qt4/include/QtCore/qrect.h:741: note: candidates are: void QRectF::getCoords(qreal*, qreal*, qreal*, qreal*) const
+| make[1]: *** [sipQtCoreQRectF.o] Error 1
+
+
S = "${WORKDIR}/PyQt-x11-gpl-${PV}"
inherit qmake qt4x11 sip distutils-base