summaryrefslogtreecommitdiff
path: root/packages/python/python-pygame_1.7.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-10-11 20:50:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-11 20:50:06 +0000
commitb3b8929c730b91d68f4a90dc5305c504bcd11bd4 (patch)
tree28831bb0a9c6d9790f3067e3149c180b1b877768 /packages/python/python-pygame_1.7.1.bb
parente48bde5b27f910fc432e55fbb5c19eea678272fa (diff)
add python-pygame 1.7.1, closes bug #387
Diffstat (limited to 'packages/python/python-pygame_1.7.1.bb')
-rw-r--r--packages/python/python-pygame_1.7.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-pygame_1.7.1.bb b/packages/python/python-pygame_1.7.1.bb
new file mode 100644
index 0000000000..429ae6fdf8
--- /dev/null
+++ b/packages/python/python-pygame_1.7.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python libSDL Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "LGPL"
+RDEPENDS = "python-core python-numeric libsdl-x11"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
+SRCNAME = "pygame"
+
+SRC_URI = "http://www.pygame.org/ftp/${SRCNAME}-${PV}release.tar.gz \
+ file://qpe.patch;patch=1 \
+ file://Setup"
+S = "${WORKDIR}/${SRCNAME}-${PV}release"
+
+inherit distutils
+
+do_configure_prepend() {
+ SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >Setup
+ cat ${WORKDIR}/Setup >>Setup
+}