summaryrefslogtreecommitdiff
path: root/packages/python/python-pydirectfb/fix-directfb-detection.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-23 10:39:46 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-23 10:39:46 +0000
commita5ab4c1e92a80b977b53072b349e05ab0f097dd1 (patch)
treec93cf04d86827b31ee317cdf0a2796be2db80175 /packages/python/python-pydirectfb/fix-directfb-detection.patch
parent9030208546561970a18f0eb4be401b4d837aa310 (diff)
parent20e5fbe217c05900868741ec16b09092eaf0830a (diff)
propagate from branch 'org.openembedded.dev' (head d8bfa63aa913e7227790ba2d02253cfbecce61ab)
to branch 'org.openembedded.dev.avr32' (head bb1b18fc3fa0562c4c7bd85bb0d9617c62261f2e)
Diffstat (limited to 'packages/python/python-pydirectfb/fix-directfb-detection.patch')
-rw-r--r--packages/python/python-pydirectfb/fix-directfb-detection.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/python/python-pydirectfb/fix-directfb-detection.patch b/packages/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644
index 0000000000..c8b7cc805a
--- /dev/null
+++ b/packages/python/python-pydirectfb/fix-directfb-detection.patch
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+ Check dependencies add add the flags to include_dirs, library_dirs and
+ libraries. The basic logic is taken from pygame.
+ """
+- command = name + '-config --version --cflags --libs 2>/dev/null'
++ command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+ try:
+ config = os.popen(command).readlines()
++ print config
+ if len(config) == 0:
+ raise ValueError, 'command not found'
+ flags = (' '.join(config[1:]) + ' ').split()