summaryrefslogtreecommitdiff
path: root/packages/python/python-pycurl
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-08-09 19:56:57 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-08-09 19:56:57 +0000
commit9d204ad1e53fcb93b3f75b8c8e68030f9e82243a (patch)
tree7a76ecf2379502cfbaf97edbb22eb3309db86bc0 /packages/python/python-pycurl
parent8f160abad51b6eba620d6ddaf3a1ebc7ee1bf2da (diff)
python-pycurl 7.16.4 update to 7.18.2; use dynamic linking
Diffstat (limited to 'packages/python/python-pycurl')
-rw-r--r--packages/python/python-pycurl/.mtn2git_empty0
-rw-r--r--packages/python/python-pycurl/no-static-link.patch14
2 files changed, 14 insertions, 0 deletions
diff --git a/packages/python/python-pycurl/.mtn2git_empty b/packages/python/python-pycurl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pycurl/.mtn2git_empty
diff --git a/packages/python/python-pycurl/no-static-link.patch b/packages/python/python-pycurl/no-static-link.patch
new file mode 100644
index 0000000000..b7c5ab9c9c
--- /dev/null
+++ b/packages/python/python-pycurl/no-static-link.patch
@@ -0,0 +1,14 @@
+Index: pycurl-7.18.2/setup.py
+===================================================================
+--- pycurl-7.18.2.orig/setup.py
++++ pycurl-7.18.2/setup.py
+@@ -97,8 +97,7 @@ else:
+ else:
+ extra_compile_args.append(e)
+ libs = split_quoted(
+- os.popen("'%s' --libs" % CURL_CONFIG).read()+\
+- os.popen("'%s' --static-libs" % CURL_CONFIG).read())
++ os.popen("'%s' --libs" % CURL_CONFIG).read())
+ for e in libs:
+ if e[:2] == "-l":
+ libraries.append(e[2:])