summaryrefslogtreecommitdiff
path: root/packages/python/python-numeric
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
commit6579e8daf68dd520b702412208bfeae85af6fadc (patch)
treeef2cfbfe3353bd39e28145995db1287bd2518b8d /packages/python/python-numeric
parentc6c085bf81bd4997bdb216e958d366ddf46438ad (diff)
make python 2.4 as default, move python-sip into python/, make sip4 as default
BKrev: 4208ff7b-sgl7QbT_1xhYPmdi-Oy4g
Diffstat (limited to 'packages/python/python-numeric')
-rw-r--r--packages/python/python-numeric/no-lapack.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/python/python-numeric/no-lapack.patch b/packages/python/python-numeric/no-lapack.patch
index e69de29bb2..d27c666ff4 100644
--- a/packages/python/python-numeric/no-lapack.patch
+++ b/packages/python/python-numeric/no-lapack.patch
@@ -0,0 +1,36 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Numeric-23.3/setup.py~no-lapack
++++ Numeric-23.3/setup.py
+@@ -32,22 +32,22 @@
+ mathlibs = []
+
+ # delete all but the first one in this list if using your own LAPACK/BLAS
+-sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
++sourcelist = [] # os.path.join('Src', 'lapack_litemodule.c'),
+ # os.path.join('Src', 'blas_lite.c'),
+ # os.path.join('Src', 'f2c_lite.c'),
+ # os.path.join('Src', 'zlapack_lite.c'),
+ # os.path.join('Src', 'dlapack_lite.c')
+- ]
++
+ # set these to use your own BLAS;
+
+-library_dirs_list = ['/usr/lib/atlas']
+-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = [] # '/usr/lib/atlas']
++libraries_list = [] # 'lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+ # if you also set `use_dotblas` (see below), you'll need:
+ # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
+
+ # set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
++use_dotblas = 0
++include_dirs = [] # '/usr/include/atlas'] # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+
+ # The packages are split in this way to allow future optional inclusion