summaryrefslogtreecommitdiff
path: root/packages/python/python-numeric
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-09 11:01:56 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-09 11:01:56 +0000
commit5d7dc2d94e88f492539761b4909a69955a5142b0 (patch)
tree0c922779ffcadcf5d2aab29530980bad1351a22f /packages/python/python-numeric
parentead81927963fb9513ffb18bc50d7f4ced7198117 (diff)
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/09 02:42:08+01:00 uni-frankfurt.de!mickeyl update python-numeric to v23.7 2005/02/09 02:02:21+01:00 uni-frankfurt.de!mickeyl fix qwt 4.2 compilage against 2.3.10. Yes, QT_VERSION again (or still *sigh*) 2005/02/09 01:44:39+01:00 uni-frankfurt.de!mickeyl fix PyQt compilage against QtE 2.3.10 (QT_VERSION again *sigh*) BKrev: 4209eda4ikLKONxgarptvjIfCJ5yOA
Diffstat (limited to 'packages/python/python-numeric')
-rw-r--r--packages/python/python-numeric/no-lapack.patch37
1 files changed, 17 insertions, 20 deletions
diff --git a/packages/python/python-numeric/no-lapack.patch b/packages/python/python-numeric/no-lapack.patch
index d27c666ff4..c1916b8b9f 100644
--- a/packages/python/python-numeric/no-lapack.patch
+++ b/packages/python/python-numeric/no-lapack.patch
@@ -3,34 +3,31 @@
# Patch managed by http://www.holgerschurig.de/patcher.html
#
---- Numeric-23.3/setup.py~no-lapack
-+++ Numeric-23.3/setup.py
-@@ -32,22 +32,22 @@
+--- Numeric-23.7/setup.py~nolapack
++++ Numeric-23.7/setup.py
+@@ -32,7 +32,7 @@
mathlibs = []
# delete all but the first one in this list if using your own LAPACK/BLAS
-sourcelist = [os.path.join('Src', 'lapack_litemodule.c'),
-+sourcelist = [] # os.path.join('Src', 'lapack_litemodule.c'),
- # os.path.join('Src', 'blas_lite.c'),
- # os.path.join('Src', 'f2c_lite.c'),
- # os.path.join('Src', 'zlapack_lite.c'),
- # os.path.join('Src', 'dlapack_lite.c')
-- ]
-+
++sourcelist = [
+ #os.path.join('Src', 'blas_lite.c'),
+ #os.path.join('Src', 'f2c_lite.c'),
+ #os.path.join('Src', 'zlapack_lite.c'),
+@@ -40,12 +40,12 @@
+ ]
# set these to use your own BLAS;
-library_dirs_list = ['/usr/lib/atlas']
-libraries_list = ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
-+library_dirs_list = [] # '/usr/lib/atlas']
-+libraries_list = [] # 'lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
- # if you also set `use_dotblas` (see below), you'll need:
- # ['lapack', 'cblas', 'f77blas', 'atlas', 'g2c']
++library_dirs_list = []
++libraries_list = []
# set to true (1), if you also want BLAS optimized matrixmultiply/dot/innerproduct
--use_dotblas = 1
--include_dirs = ['/usr/include/atlas'] # You may need to set this to find cblas.h
+-use_dotblas = 1
+-include_dirs = ['/usr/include/atlas']
+use_dotblas = 0
-+include_dirs = [] # '/usr/include/atlas'] # You may need to set this to find cblas.h
- # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
-
- # The packages are split in this way to allow future optional inclusion
++include_dirs = []
+ # You may need to set this to find cblas.h
+ # e.g. on UNIX using ATLAS this should be ['/usr/include/atlas']
+ extra_link_args = []