summaryrefslogtreecommitdiff
path: root/packages/python/python-mysqldb_1.2.1.bb
diff options
context:
space:
mode:
authorquickdev <niklas.coding@gmail.com>2009-01-24 17:13:32 +0100
committerquickdev <niklas.coding@gmail.com>2009-01-24 17:13:32 +0100
commit3c635ab244b48708901e5763fb6c3345b9ce5190 (patch)
tree4f197afe9b2f705bdb2c809d29b76fbbc63ad470 /packages/python/python-mysqldb_1.2.1.bb
parenteb0493f0ebee9c0baf9bbec020cfeb8a3e82b227 (diff)
python-mysqldb: Modified patch to properly compile. Removed it from nonworking.
Before, bitbake failed with "CROSS COMPILE Badness: /usr/include in INCLUDEPATH: /usr/include/mysql". The patch modification adds a new line in site.cfg, which removes /usr/include/mysql from INCLUDEPATH.
Diffstat (limited to 'packages/python/python-mysqldb_1.2.1.bb')
-rw-r--r--packages/python/python-mysqldb_1.2.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-mysqldb_1.2.1.bb b/packages/python/python-mysqldb_1.2.1.bb
new file mode 100644
index 0000000000..9a9ca0fe56
--- /dev/null
+++ b/packages/python/python-mysqldb_1.2.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python interface to MySQL"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "mysql"
+SRCNAME = "MySQL-python"
+
+inherit distutils
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/mysql-python/MySQL-python-${PV}_p2.tar.gz \
+ file://mysqlpath.patch;patch=1 \
+ file://site.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}_p2"
+
+do_install_append() {
+ install -d ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/doc/*.txt ${D}${datadir}/doc/${PN}/
+}