summaryrefslogtreecommitdiff
path: root/packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-12-10 12:08:42 -0800
committerKhem Raj <raj.khem@gmail.com>2008-12-10 12:08:42 -0800
commitc83835dca4b2a8f8267066037c86a71474f278c2 (patch)
treeb8645ff1fa623a7b8ce5496a62c2f2a01fd87887 /packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch
parentfca5cadc1e2012f01afcdd67d9482a4c52aa52d1 (diff)
parent1a184ff3d7b13923c4b7cd94866307ac8f399bed (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch')
-rw-r--r--packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch b/packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch
new file mode 100644
index 0000000000..2559e3a0e4
--- /dev/null
+++ b/packages/python/python-2.6.1/00-fix-bindir-libdir-for-cross.patch
@@ -0,0 +1,20 @@
+# $(exec_prefix) points to the wrong directory, when installing
+# a cross-build. @bindir@ and @libdir@ works better and doesn't
+# affect the native build.
+# Signed-Off: Michael 'Mickey' Lauer <mickey@vanille-media.de>
+
+Index: Python-2.6.1/Makefile.pre.in
+===================================================================
+--- Python-2.6.1.orig/Makefile.pre.in
++++ Python-2.6.1/Makefile.pre.in
+@@ -86,8 +86,8 @@ exec_prefix= @exec_prefix@
+ datarootdir= @datarootdir@
+
+ # Expanded directories
+-BINDIR= $(exec_prefix)/bin
+-LIBDIR= $(exec_prefix)/lib
++BINDIR= @bindir@
++LIBDIR= @libdir@
+ MANDIR= @mandir@
+ INCLUDEDIR= @includedir@
+ CONFINCLUDEDIR= $(exec_prefix)/include