summaryrefslogtreecommitdiff
path: root/packages/python/python-2.5.2
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-10 19:42:38 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-10 19:42:38 +0000
commit7fb704a0d10a35270c97ef20d47b7d57963341d8 (patch)
tree35965c269949dafef02ededf138aa666687cd614 /packages/python/python-2.5.2
parent81b581a29c364b248359ceef82533bf2c32c71af (diff)
python: remove 2.4 and 2.5
Diffstat (limited to 'packages/python/python-2.5.2')
-rw-r--r--packages/python/python-2.5.2/05-install.patch13
-rw-r--r--packages/python/python-2.5.2/06-fix-urllib-exception.patch13
-rw-r--r--packages/python/python-2.5.2/13-set-wakeup-fix.patch87
-rw-r--r--packages/python/python-2.5.2/14-encodings-oriental.patch64
-rw-r--r--packages/python/python-2.5.2/16-bug1179-imageop.patch219
-rw-r--r--packages/python/python-2.5.2/autohell.patch50
-rw-r--r--packages/python/python-2.5.2/bindir-libdir.patch20
-rw-r--r--packages/python/python-2.5.2/crosscompile.patch110
-rw-r--r--packages/python/python-2.5.2/default-is-optimized.patch48
-rw-r--r--packages/python/python-2.5.2/enable-ctypes-module.patch106
-rw-r--r--packages/python/python-2.5.2/fix-tkinter-detection.patch41
-rw-r--r--packages/python/python-2.5.2/sitebranding.patch21
-rw-r--r--packages/python/python-2.5.2/sitecustomize.py45
13 files changed, 0 insertions, 837 deletions
diff --git a/packages/python/python-2.5.2/05-install.patch b/packages/python/python-2.5.2/05-install.patch
deleted file mode 100644
index c3e249db1c..0000000000
--- a/packages/python/python-2.5.2/05-install.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: python/Lib/distutils/command/install.py
-===================================================================
---- python.orig/Lib/distutils/command/install.py 2007-03-06 17:15:43.000000000 -0300
-+++ python/Lib/distutils/command/install.py 2007-03-06 17:16:04.000000000 -0300
-@@ -601,7 +601,7 @@
- ('install_headers', has_headers),
- ('install_scripts', has_scripts),
- ('install_data', has_data),
-- ('install_egg_info', lambda self:True),
-+ ('install_egg_info', lambda self:False),
- ]
-
- # class install
diff --git a/packages/python/python-2.5.2/06-fix-urllib-exception.patch b/packages/python/python-2.5.2/06-fix-urllib-exception.patch
deleted file mode 100644
index d096ee9402..0000000000
--- a/packages/python/python-2.5.2/06-fix-urllib-exception.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: python/Lib/urllib.py
-===================================================================
---- python.orig/Lib/urllib.py 2007-03-06 17:16:49.000000000 -0300
-+++ python/Lib/urllib.py 2007-03-06 17:17:05.000000000 -0300
-@@ -358,7 +358,7 @@
- """Default error handler: close the connection and raise IOError."""
- void = fp.read()
- fp.close()
-- raise IOError, ('http error', errcode, errmsg, headers)
-+ raise IOError, ('http error', errcode, errmsg)
-
- if hasattr(socket, "ssl"):
- def open_https(self, url, data=None):
diff --git a/packages/python/python-2.5.2/13-set-wakeup-fix.patch b/packages/python/python-2.5.2/13-set-wakeup-fix.patch
deleted file mode 100644
index 807014b7a7..0000000000
--- a/packages/python/python-2.5.2/13-set-wakeup-fix.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-Index: python-2.5.2/Modules/signalmodule.c
-===================================================================
---- python-2.5.2.orig/Modules/signalmodule.c 2008-02-23 13:10:12.000000000 -0300
-+++ python-2.5.2/Modules/signalmodule.c 2008-02-23 13:10:48.000000000 -0300
-@@ -12,6 +12,8 @@
-
- #include <signal.h>
-
-+#include <sys/stat.h>
-+
- #ifndef SIG_ERR
- #define SIG_ERR ((PyOS_sighandler_t)(-1))
- #endif
-@@ -75,6 +77,8 @@
- PyObject *func;
- } Handlers[NSIG];
-
-+static sig_atomic_t wakeup_fd = -1;
-+
- /* Speed up sigcheck() when none tripped */
- static volatile sig_atomic_t is_tripped = 0;
-
-@@ -113,6 +117,7 @@
- static void
- signal_handler(int sig_num)
- {
-+ const char dummy_byte = '\0';
- #ifdef WITH_THREAD
- #ifdef WITH_PTH
- if (PyThread_get_thread_ident() != main_thread) {
-@@ -128,6 +133,8 @@
- cleared in PyErr_CheckSignals() before .tripped. */
- is_tripped = 1;
- Py_AddPendingCall(checksignals_witharg, NULL);
-+ if (wakeup_fd != -1)
-+ write(wakeup_fd, &dummy_byte, 1);
- #ifdef WITH_THREAD
- }
- #endif
-@@ -267,6 +274,39 @@
- anything else -- the callable Python object used as a handler");
-
-
-+static PyObject *
-+signal_set_wakeup_fd(PyObject *self, PyObject *args)
-+{
-+ struct stat buf;
-+ int fd, old_fd;
-+ if (!PyArg_ParseTuple(args, "i:set_wakeup_fd", &fd))
-+ return NULL;
-+#ifdef WITH_THREAD
-+ if (PyThread_get_thread_ident() != main_thread) {
-+ PyErr_SetString(PyExc_ValueError,
-+ "set_wakeup_fd only works in main thread");
-+ return NULL;
-+ }
-+#endif
-+ if (fd != -1 && fstat(fd, &buf) != 0) {
-+ PyErr_SetString(PyExc_ValueError, "invalid fd");
-+ return NULL;
-+ }
-+ old_fd = wakeup_fd;
-+ wakeup_fd = fd;
-+ return PyLong_FromLong(old_fd);
-+}
-+
-+PyDoc_STRVAR(set_wakeup_fd_doc,
-+"set_wakeup_fd(fd) -> fd\n\
-+\n\
-+Sets the fd to be written to (with '\\0') when a signal\n\
-+comes in. A library can use this to wakeup select or poll.\n\
-+The previous fd is returned.\n\
-+\n\
-+The fd must be non-blocking.");
-+
-+
- /* List of functions defined in the module */
- static PyMethodDef signal_methods[] = {
- #ifdef HAVE_ALARM
-@@ -274,6 +314,7 @@
- #endif
- {"signal", signal_signal, METH_VARARGS, signal_doc},
- {"getsignal", signal_getsignal, METH_VARARGS, getsignal_doc},
-+ {"set_wakeup_fd", signal_set_wakeup_fd, METH_VARARGS, set_wakeup_fd_doc},
- #ifdef HAVE_PAUSE
- {"pause", (PyCFunction)signal_pause,
- METH_NOARGS,pause_doc},
diff --git a/packages/python/python-2.5.2/14-encodings-oriental.patch b/packages/python/python-2.5.2/14-encodings-oriental.patch
deleted file mode 100644
index 4c942f1b75..0000000000
--- a/packages/python/python-2.5.2/14-encodings-oriental.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-Index: python-2.5.2/debian/rules
-===================================================================
---- python-2.5.2.orig/debian/rules 2008-02-26 14:15:36.000000000 -0300
-+++ python-2.5.2/debian/rules 2008-02-26 14:17:42.000000000 -0300
-@@ -134,6 +134,8 @@
- )
- find $(d_dev)/$(scriptdir) -name "*.pyo" -type f | grep -v -f $(only_dev_list) | xargs rm -f
-
-+ find $(d_dev)/$(scriptdir)/encodings | grep -f $(only_dev_list) | xargs -i mv '{}' $(d_dev)/$(scriptdir)/encodings_orient
-+
- # move the interpreter
- mv $(d_dev)/usr/bin/python2.5 $(d_base)/usr/bin/python2.5
-
-Index: python-2.5.2/Lib/encodings/__init__.py
-===================================================================
---- python-2.5.2.orig/Lib/encodings/__init__.py 2008-02-26 14:15:07.000000000 -0300
-+++ python-2.5.2/Lib/encodings/__init__.py 2008-02-26 14:17:42.000000000 -0300
-@@ -99,6 +99,14 @@
- pass
- else:
- break
-+
-+ try:
-+ mod = __import__('encodings_orient.' + modname,
-+ globals(), locals(), _import_tail)
-+ except ImportError:
-+ pass
-+ else:
-+ break
- else:
- mod = None
-
-Index: python-2.5.2/Makefile.pre.in
-===================================================================
---- python-2.5.2.orig/Makefile.pre.in 2008-02-26 14:15:07.000000000 -0300
-+++ python-2.5.2/Makefile.pre.in 2008-02-26 14:17:42.000000000 -0300
-@@ -717,7 +717,7 @@
- PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
- LIBSUBDIRS= lib-tk site-packages test test/output test/data \
- test/decimaltestdata \
-- encodings compiler hotshot \
-+ encodings encodings_orient compiler hotshot \
- email email/mime email/test email/test/data \
- sqlite3 sqlite3/test \
- logging bsddb bsddb/test csv wsgiref \
-Index: python-2.5.2/debian/onlysdk
-===================================================================
---- python-2.5.2.orig/debian/onlysdk 2008-02-26 14:15:07.000000000 -0300
-+++ python-2.5.2/debian/onlysdk 2008-02-26 14:17:42.000000000 -0300
-@@ -1,7 +1,6 @@
- distutils
- compile
--encodings/cp
--encodings/mac
-+encodings_orient
- doctest
- unittest
- hotshot
-Index: python-2.5.2/Lib/encodings_orient/__init__.py
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ python-2.5.2/Lib/encodings_orient/__init__.py 2008-02-26 14:17:42.000000000 -0300
-@@ -0,0 +1 @@
-+#Dummy
diff --git a/packages/python/python-2.5.2/16-bug1179-imageop.patch b/packages/python/python-2.5.2/16-bug1179-imageop.patch
deleted file mode 100644
index 895d4e0a17..0000000000
--- a/packages/python/python-2.5.2/16-bug1179-imageop.patch
+++ /dev/null
@@ -1,219 +0,0 @@
-Index: python-2.5.2/Modules/imageop.c
-===================================================================
---- python-2.5.2.orig/Modules/imageop.c 2006-01-19 03:09:39.000000000 -0300
-+++ python-2.5.2/Modules/imageop.c 2008-04-07 16:29:09.000000000 -0300
-@@ -78,7 +78,7 @@
- char *cp, *ncp;
- short *nsp;
- Py_Int32 *nlp;
-- int len, size, x, y, newx1, newx2, newy1, newy2;
-+ int len, size, x, y, newx1, newx2, newy1, newy2, nlen;
- int ix, iy, xstep, ystep;
- PyObject *rv;
-
-@@ -90,13 +90,19 @@
- PyErr_SetString(ImageopError, "Size should be 1, 2 or 4");
- return 0;
- }
-- if ( len != size*x*y ) {
-+ if (( len != size*x*y ) ||
-+ ( size != ((len / x) / y) )) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
- xstep = (newx1 < newx2)? 1 : -1;
- ystep = (newy1 < newy2)? 1 : -1;
-
-+ nlen = (abs(newx2-newx1)+1)*(abs(newy2-newy1)+1)*size;
-+ if ( size != ((nlen / (abs(newx2-newx1)+1)) / (abs(newy2-newy1)+1)) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- rv = PyString_FromStringAndSize(NULL,
- (abs(newx2-newx1)+1)*(abs(newy2-newy1)+1)*size);
- if ( rv == 0 )
-@@ -132,7 +138,7 @@
- char *cp, *ncp;
- short *nsp;
- Py_Int32 *nlp;
-- int len, size, x, y, newx, newy;
-+ int len, size, x, y, newx, newy, nlen;
- int ix, iy;
- int oix, oiy;
- PyObject *rv;
-@@ -145,12 +151,18 @@
- PyErr_SetString(ImageopError, "Size should be 1, 2 or 4");
- return 0;
- }
-- if ( len != size*x*y ) {
-+ if ( ( len != size*x*y ) ||
-+ ( size != ((len / x) / y) ) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
-+ nlen = newx*newy*size;
-+ if ( size != ((nlen / newx) / newy) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-
-- rv = PyString_FromStringAndSize(NULL, newx*newy*size);
-+ rv = PyString_FromStringAndSize(NULL, nlen);
- if ( rv == 0 )
- return 0;
- ncp = (char *)PyString_AsString(rv);
-@@ -190,7 +202,8 @@
- PyErr_SetString(ImageopError, "Size should be 1 or 4");
- return 0;
- }
-- if ( maxx*maxy*width != len ) {
-+ if ( ( maxx*maxy*width != len ) ||
-+ ( maxx != ((len / maxy) / width) ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -240,7 +253,8 @@
- if ( !PyArg_ParseTuple(args, "s#iii", &cp, &len, &x, &y, &tres) )
- return 0;
-
-- if ( x*y != len ) {
-+ if ( ( x*y != len ) ||
-+ ( x != len / y ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -281,7 +295,8 @@
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ if ( ( x*y != len ) ||
-+ ( x != len / y ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -320,7 +335,8 @@
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ if ( ( x*y != len ) ||
-+ ( x != len / y ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -358,7 +374,8 @@
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ if ( ( x*y != len ) ||
-+ ( x != len / y ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -404,7 +421,8 @@
- if ( !PyArg_ParseTuple(args, "s#ii", &cp, &len, &x, &y) )
- return 0;
-
-- if ( x*y != len ) {
-+ if ( ( x*y != len ) ||
-+ ( x != len / y ) ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
- }
-@@ -443,7 +461,11 @@
- if ( !PyArg_ParseTuple(args, "s#iiii", &cp, &len, &x, &y, &v0, &v1) )
- return 0;
-
-- nlen = x*y;
-+ nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+7)/8 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -481,6 +503,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+3)/4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -517,6 +543,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( (nlen+1)/2 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -554,6 +584,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen*4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -598,6 +632,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -648,6 +686,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen*4 != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-@@ -693,6 +735,10 @@
- return 0;
-
- nlen = x*y;
-+ if ( x != (nlen / y) ) {
-+ PyErr_SetString(ImageopError, "String has incorrect length");
-+ return 0;
-+ }
- if ( nlen != len ) {
- PyErr_SetString(ImageopError, "String has incorrect length");
- return 0;
-Index: python-2.5.2/Modules/rgbimgmodule.c
-===================================================================
---- python-2.5.2.orig/Modules/rgbimgmodule.c 2008-02-14 08:26:18.000000000 -0300
-+++ python-2.5.2/Modules/rgbimgmodule.c 2008-04-07 16:29:10.000000000 -0300
-@@ -299,6 +299,11 @@
- xsize = image.xsize;
- ysize = image.ysize;
- zsize = image.zsize;
-+ tablen = xsize * ysize * zsize * sizeof(Py_Int32);
-+ if (xsize != (((tablen / ysize) / zsize) / sizeof(Py_Int32))) {
-+ PyErr_NoMemory();
-+ goto finally;
-+ }
- if (rle) {
- tablen = ysize * zsize * sizeof(Py_Int32);
- rlebuflen = (int) (1.05 * xsize +10);
diff --git a/packages/python/python-2.5.2/autohell.patch b/packages/python/python-2.5.2/autohell.patch
deleted file mode 100644
index 32977955d4..0000000000
--- a/packages/python/python-2.5.2/autohell.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Index: Python-2.5.2/configure.in
-===================================================================
---- Python-2.5.2.orig/configure.in
-+++ Python-2.5.2/configure.in
-@@ -3410,45 +3410,6 @@ esac
-
-
-
--AC_MSG_CHECKING(for %zd printf() format support)
--AC_TRY_RUN([#include <stdio.h>
--#include <stddef.h>
--#include <string.h>
--
--#ifdef HAVE_SYS_TYPES_H
--#include <sys/types.h>
--#endif
--
--#ifdef HAVE_SSIZE_T
--typedef ssize_t Py_ssize_t;
--#elif SIZEOF_VOID_P == SIZEOF_LONG
--typedef long Py_ssize_t;
--#else
--typedef int Py_ssize_t;
--#endif
--
--int main()
--{
-- char buffer[256];
--
-- if(sprintf(buffer, "%zd", (size_t)123) < 0)
-- return 1;
--
-- if (strcmp(buffer, "123"))
-- return 1;
--
-- if (sprintf(buffer, "%zd", (Py_ssize_t)-123) < 0)
-- return 1;
--
-- if (strcmp(buffer, "-123"))
-- return 1;
--
-- return 0;
--}],
--[AC_MSG_RESULT(yes)
-- AC_DEFINE(PY_FORMAT_SIZE_T, "z", [Define to printf format modifier for Py_ssize_t])],
-- AC_MSG_RESULT(no))
--
- AC_CHECK_TYPE(socklen_t,,
- AC_DEFINE(socklen_t,int,
- Define to `int' if <sys/socket.h> does not define.),[
diff --git a/packages/python/python-2.5.2/bindir-libdir.patch b/packages/python/python-2.5.2/bindir-libdir.patch
deleted file mode 100644
index 047c358a55..0000000000
--- a/packages/python/python-2.5.2/bindir-libdir.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: Python-2.5.1/Makefile.pre.in
-===================================================================
---- Python-2.5.1.orig/Makefile.pre.in
-+++ Python-2.5.1/Makefile.pre.in
-@@ -83,8 +83,8 @@ prefix= @prefix@
- exec_prefix= @exec_prefix@
-
- # Expanded directories
--BINDIR= $(exec_prefix)/bin
--LIBDIR= $(exec_prefix)/lib
-+BINDIR= @bindir@
-+LIBDIR= @libdir@
- MANDIR= @mandir@
- INCLUDEDIR= @includedir@
- CONFINCLUDEDIR= $(exec_prefix)/include
diff --git a/packages/python/python-2.5.2/crosscompile.patch b/packages/python/python-2.5.2/crosscompile.patch
deleted file mode 100644
index f1b1c6f3e0..0000000000
--- a/packages/python/python-2.5.2/crosscompile.patch
+++ /dev/null
@@ -1,110 +0,0 @@
-#
-# Patch (C) by Michael 'Mickey' Lauer <mlauer@vanille-media.de>
-#
-Index: Python-2.5.2/Makefile.pre.in
-===================================================================
---- Python-2.5.2.orig/Makefile.pre.in
-+++ Python-2.5.2/Makefile.pre.in
-@@ -173,6 +173,7 @@ UNICODE_OBJS= @UNICODE_OBJS@
-
- PYTHON= python$(EXE)
- BUILDPYTHON= python$(BUILDEXE)
-+HOSTPYTHON= $(BUILDPYTHON)
-
- # === Definitions added by makesetup ===
-
-@@ -199,7 +200,7 @@ GRAMMAR_INPUT= $(srcdir)/Grammar/Grammar
- ##########################################################################
- # Parser
- PGEN= Parser/pgen$(EXE)
--
-+HOSTPGEN= $(PGEN)$(EXE)
- POBJS= \
- Parser/acceler.o \
- Parser/grammar1.o \
-@@ -348,8 +349,8 @@ platform: $(BUILDPYTHON)
- # Build the shared modules
- sharedmods: $(BUILDPYTHON)
- case $$MAKEFLAGS in \
-- *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
-- *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
-+ *-s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
-+ *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
- esac
-
- # Build static library
-@@ -474,7 +475,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
-
- $(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
- -@ mkdir Include
-- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
-+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
-
- $(PGEN): $(PGENOBJS)
- $(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-@@ -782,19 +783,19 @@ libinstall: $(BUILDPYTHON) $(srcdir)/Lib
- done
- $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-- ./$(BUILDPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
-+ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f \
- -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
- PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-- ./$(BUILDPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
-+ $(HOSTPYTHON) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST) -f \
- -x 'bad_coding|badsyntax|site-packages' $(DESTDIR)$(LIBDEST)
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-- ./$(BUILDPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
-+ $(HOSTPYTHON) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f \
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
-- ./$(BUILDPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
-+ $(HOSTPYTHON) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
- -d $(LIBDEST)/site-packages -f \
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
-
-@@ -894,7 +895,7 @@ libainstall: all
- # Install the dynamically loadable modules
- # This goes into $(exec_prefix)
- sharedinstall:
-- $(RUNSHARED) ./$(BUILDPYTHON) -E $(srcdir)/setup.py install \
-+ $(RUNSHARED) $(HOSTPYTHON) -E $(srcdir)/setup.py install \
- --prefix=$(prefix) \
- --install-scripts=$(BINDIR) \
- --install-platlib=$(DESTSHARED) \
-Index: Python-2.5.2/setup.py
-===================================================================
---- Python-2.5.2.orig/setup.py
-+++ Python-2.5.2/setup.py
-@@ -211,6 +211,7 @@ class PyBuildExt(build_ext):
- except ImportError, why:
- self.announce('*** WARNING: renaming "%s" since importing it'
- ' failed: %s' % (ext.name, why), level=3)
-+ return
- assert not self.inplace
- basename, tail = os.path.splitext(ext_filename)
- newname = basename + "_failed" + tail
-@@ -244,8 +245,8 @@ class PyBuildExt(build_ext):
-
- def detect_modules(self):
- # Ensure that /usr/local is always used
-- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-+ # add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
-+ # add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
-
- # Add paths specified in the environment variables LDFLAGS and
- # CPPFLAGS for header and library files.
-@@ -342,6 +343,9 @@ class PyBuildExt(build_ext):
-
- # XXX Omitted modules: gl, pure, dl, SGI-specific modules
-
-+ lib_dirs = [ os.getenv( "STAGING_LIBDIR" ) ]
-+ inc_dirs = [ os.getenv( "STAGING_INCDIR" ) ]
-+
- #
- # The following modules are all pretty straightforward, and compile
- # on pretty much any POSIXish platform.
diff --git a/packages/python/python-2.5.2/default-is-optimized.patch b/packages/python/python-2.5.2/default-is-optimized.patch
deleted file mode 100644
index 072bf0b059..0000000000
--- a/packages/python/python-2.5.2/default-is-optimized.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-Index: Python-2.5.2/Python/compile.c
-===================================================================
---- Python-2.5.2.orig/Python/compile.c
-+++ Python-2.5.2/Python/compile.c
-@@ -30,7 +30,7 @@
- #include "symtable.h"
- #include "opcode.h"
-
--int Py_OptimizeFlag = 0;
-+int Py_OptimizeFlag = 1;
-
- /*
- ISSUES:
-Index: Python-2.5.2/Modules/main.c
-===================================================================
---- Python-2.5.2.orig/Modules/main.c
-+++ Python-2.5.2/Modules/main.c
-@@ -40,7 +40,7 @@ static char **orig_argv;
- static int orig_argc;
-
- /* command line options */
--#define BASE_OPTS "c:dEhim:OQ:StuUvVW:xX?"
-+#define BASE_OPTS "c:dEhim:ONQ:StuUvVW:xX?"
-
- #ifndef RISCOS
- #define PROGRAM_OPTS BASE_OPTS
-@@ -68,8 +68,7 @@ Options and arguments (and corresponding
- ";
- static char *usage_2 = "\
- -m mod : run library module as a script (terminates option list)\n\
---O : optimize generated bytecode (a tad; also PYTHONOPTIMIZE=x)\n\
---OO : remove doc-strings in addition to the -O optimizations\n\
-+-N : do NOT optimize generated bytecode\n\
- -Q arg : division options: -Qold (default), -Qwarn, -Qwarnall, -Qnew\n\
- -S : don't imply 'import site' on initialization\n\
- -t : issue warnings about inconsistent tab usage (-tt: issue errors)\n\
-@@ -302,7 +301,10 @@ Py_Main(int argc, char **argv)
- break;
-
- case 'O':
-- Py_OptimizeFlag++;
-+ fprintf(stderr, "-O is already default in this version. Ignoring\n");
-+
-+ case 'N':
-+ Py_OptimizeFlag=0;
- break;
-
- case 'S':
diff --git a/packages/python/python-2.5.2/enable-ctypes-module.patch b/packages/python/python-2.5.2/enable-ctypes-module.patch
deleted file mode 100644
index dd5adaf0e7..0000000000
--- a/packages/python/python-2.5.2/enable-ctypes-module.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff -Naur Python-2.5.1.orig/setup.py Python-2.5.1/setup.py
---- Python-2.5.orig/setup.py 2006-08-10 01:42:18.000000000 +0200
-+++ Python-2.5/setup.py 2007-11-21 18:00:43.000000000 +0100
-@@ -1321,16 +1329,16 @@
- ffi_configfile):
- from distutils.dir_util import mkpath
- mkpath(ffi_builddir)
-- config_args = []
-+ config_args = ['--host=%s' % os.environ["HOST_SYS"], ]
-
- # Pass empty CFLAGS because we'll just append the resulting
- # CFLAGS to Python's; -g or -O2 is to be avoided.
-- cmd = "cd %s && env CFLAGS='' '%s/configure' %s" \
-- % (ffi_builddir, ffi_srcdir, " ".join(config_args))
-+ cmd = "(cd %s && autoconf -W cross) && (cd %s && env CFLAGS='' '%s/configure' %s)" \
-+ % (ffi_srcdir, ffi_builddir, ffi_srcdir, " ".join(config_args))
-
- res = os.system(cmd)
- if res or not os.path.exists(ffi_configfile):
-- print "Failed to configure _ctypes module"
-+ print "Failed to configure _ctypes module, ret %d or missing %s"% (res, ffi_configfile, )
- return False
-
- fficonfig = {}
-diff -Naur Python-2.5.1.orig/Modules/_ctypes/callbacks.c Python-2.5.1/Modules/_ctypes/callbacks.c
---- Python-2.5.1.orig/Modules/_ctypes/callbacks.c 2006-10-17 21:41:10.000000000 +0200
-+++ Python-2.5.1/Modules/_ctypes/callbacks.c 2007-11-22 10:29:33.000000000 +0100
-@@ -273,11 +273,13 @@
- PyErr_NoMemory();
- return NULL;
- }
-+#if FFI_CLOSURES
- p->pcl = MallocClosure();
- if (p->pcl == NULL) {
- PyErr_NoMemory();
- goto error;
- }
-+#endif
-
- for (i = 0; i < nArgs; ++i) {
- PyObject *cnv = PySequence_GetItem(converters, i);
-@@ -315,12 +317,14 @@
- "ffi_prep_cif failed with %d", result);
- goto error;
- }
-+#if FFI_CLOSURES
- result = ffi_prep_closure(p->pcl, &p->cif, closure_fcn, p);
- if (result != FFI_OK) {
- PyErr_Format(PyExc_RuntimeError,
- "ffi_prep_closure failed with %d", result);
- goto error;
- }
-+#endif
-
- p->converters = converters;
- p->callable = callable;
-@@ -328,8 +332,10 @@
-
- error:
- if (p) {
-+#if FFI_CLOSURES
- if (p->pcl)
- FreeClosure(p->pcl);
-+#endif
- PyMem_Free(p);
- }
- return NULL;
-diff -Naur Python-2.5.1.orig/Modules/_ctypes/_ctypes.c Python-2.5.1/Modules/_ctypes/_ctypes.c
---- Python-2.5.1.orig/Modules/_ctypes/_ctypes.c 2007-03-23 20:56:45.000000000 +0100
-+++ Python-2.5.1/Modules/_ctypes/_ctypes.c 2007-11-22 10:29:01.000000000 +0100
-@@ -3419,7 +3419,9 @@
- Py_CLEAR(self->paramflags);
-
- if (self->thunk) {
-+#if FFI_CLOSURES
- FreeClosure(self->thunk->pcl);
-+#endif
- PyMem_Free(self->thunk);
- self->thunk = NULL;
- }
-diff -Naur Python-2.5.1.orig/Modules/_ctypes/ctypes.h Python-2.5.1/Modules/_ctypes/ctypes.h
---- Python-2.5.1.orig/Modules/_ctypes/ctypes.h 2006-08-14 13:17:48.000000000 +0200
-+++ Python-2.5.1/Modules/_ctypes/ctypes.h 2007-11-22 10:29:44.000000000 +0100
-@@ -68,7 +68,9 @@
- };
-
- typedef struct {
-+#if FFI_CLOSURES
- ffi_closure *pcl; /* the C callable */
-+#endif
- ffi_cif cif;
- PyObject *converters;
- PyObject *callable;
-diff -Naur Python-2.5.1.orig/Modules/_ctypes/malloc_closure.c Python-2.5.1/Modules/_ctypes/malloc_closure.c
---- Python-2.5.1.orig/Modules/_ctypes/malloc_closure.c 2006-06-12 22:56:48.000000000 +0200
-+++ Python-2.5.1/Modules/_ctypes/malloc_closure.c 2007-11-22 10:30:17.000000000 +0100
-@@ -27,7 +27,9 @@
- /******************************************************************/
-
- typedef union _tagITEM {
-+#if FFI_CLOSURES
- ffi_closure closure;
-+#endif
- union _tagITEM *next;
- } ITEM;
-
diff --git a/packages/python/python-2.5.2/fix-tkinter-detection.patch b/packages/python/python-2.5.2/fix-tkinter-detection.patch
deleted file mode 100644
index 93bd343381..0000000000
--- a/packages/python/python-2.5.2/fix-tkinter-detection.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: Python-2.5.1/setup.py
-===================================================================
---- Python-2.5.1.orig/setup.py
-+++ Python-2.5.1/setup.py
-@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
- dotversion = dotversion[:-1] + '.' + dotversion[-1]
- tcl_include_sub = []
- tk_include_sub = []
-- for dir in inc_dirs:
-+ for dir in [os.getenv("STAGING_INCDIR")]:
- tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
- tk_include_sub += [dir + os.sep + "tk" + dotversion]
- tk_include_sub += tcl_include_sub
-@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
- if dir not in include_dirs:
- include_dirs.append(dir)
-
-- # Check for various platform-specific directories
-- if platform == 'sunos5':
-- include_dirs.append('/usr/openwin/include')
-- added_lib_dirs.append('/usr/openwin/lib')
-- elif os.path.exists('/usr/X11R6/include'):
-- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/lib64')
-- added_lib_dirs.append('/usr/X11R6/lib')
-- elif os.path.exists('/usr/X11R5/include'):
-- include_dirs.append('/usr/X11R5/include')
-- added_lib_dirs.append('/usr/X11R5/lib')
-- else:
-- # Assume default location for X11
-- include_dirs.append('/usr/X11/include')
-- added_lib_dirs.append('/usr/X11/lib')
--
- # If Cygwin, then verify that X is installed before proceeding
- if platform == 'cygwin':
- x11_inc = find_file('X11/Xlib.h', [], include_dirs)
diff --git a/packages/python/python-2.5.2/sitebranding.patch b/packages/python/python-2.5.2/sitebranding.patch
deleted file mode 100644
index c6e486ae97..0000000000
--- a/packages/python/python-2.5.2/sitebranding.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: Python-2.5.1/Lib/site.py
-===================================================================
---- Python-2.5.1.orig/Lib/site.py
-+++ Python-2.5.1/Lib/site.py
-@@ -323,8 +323,9 @@ def setcopyright():
- "Jython is maintained by the Jython developers (www.jython.org).")
- else:
- __builtin__.credits = _Printer("credits", """\
-- Thanks to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
-- for supporting Python development. See www.python.org for more information.""")
-+ This version of Python has been built by the OpenEmbedded buildsystem (http://openembedded.org).
-+ It is a part of the Python-For-Embedded-Systems initiative which is maintained by
-+ Michael 'Mickey' Lauer (http://www.Vanille.de/projects/python.spy).""")
- here = os.path.dirname(os.__file__)
- __builtin__.license = _Printer(
- "license", "See http://www.python.org/%.3s/license.html" % sys.version,
diff --git a/packages/python/python-2.5.2/sitecustomize.py b/packages/python/python-2.5.2/sitecustomize.py
deleted file mode 100644
index 273901898a..0000000000
--- a/packages/python/python-2.5.2/sitecustomize.py
+++ /dev/null
@@ -1,45 +0,0 @@
-# OpenEmbedded sitecustomize.py (C) 2002-2008 Michael 'Mickey' Lauer <mlauer@vanille-media.de>
-# GPLv2 or later
-# Version: 20081123
-# Features:
-# * set proper default encoding
-# * enable readline completion in the interactive interpreter
-# * load command line history on startup
-# * save command line history on exit
-
-import os
-
-def __exithandler():
- try:
- readline.write_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
- except IOError:
- pass
-
-def __registerExitHandler():
- import atexit
- atexit.register( __exithandler )
-
-def __enableReadlineSupport():
- readline.set_history_length( 1000 )
- readline.parse_and_bind( "tab: complete" )
- try:
- readline.read_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
- except IOError:
- pass
-
-def __enableDefaultEncoding():
- import sys
- try:
- sys.setdefaultencoding( "utf8" )
- except LookupError:
- pass
-
-import sys
-try:
- import rlcompleter, readline
-except ImportError:
- pass
-else:
- __enableDefaultEncoding()
- __registerExitHandler()
- __enableReadlineSupport()