summaryrefslogtreecommitdiff
path: root/packages/pwlib/pwlib_1.5.2.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-05-31 22:44:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 22:44:14 +0000
commit07275ebdb8061d2b6a820aa30dfc9b30cf6da23f (patch)
treee4422ff0f65d0bc36267dd5af730ed3c731b6c30 /packages/pwlib/pwlib_1.5.2.bb
parent962a5d9c8fdc4e70aa50e63bc9f29e5d439e64b9 (diff)
pwlib - Initial add
Diffstat (limited to 'packages/pwlib/pwlib_1.5.2.bb')
-rw-r--r--packages/pwlib/pwlib_1.5.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/pwlib/pwlib_1.5.2.bb b/packages/pwlib/pwlib_1.5.2.bb
new file mode 100644
index 0000000000..c30ba80f96
--- /dev/null
+++ b/packages/pwlib/pwlib_1.5.2.bb
@@ -0,0 +1,33 @@
+# pwlib .bb build file
+# Copyright (C) 2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+HOMEPAGE="http://www.openh323.org/docs/PWLib/"
+DESCRIPTION="Portable Text and GUI C/C++ Class Libarary."
+MAINTAINER = "Raymond Danks <info-linux@geode.amd.com>"
+LICENSE = "GPL"
+
+SRC_URI="http://www.openh323.org/bin/${PN}_${PV}.tar.gz"
+DEPENDS="openssl openldap"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-ipv6 --disable-sasl --disable-sdl \
+ --disable-video --enable-plugins --with-plugins=oss"
+
+S="${WORKDIR}/${PN}"
+
+# Use openSSL
+
+export OPENSSLFLAG=1
+export OPENSSLDIR="${STAGING_LIBDIR}"
+export OPENSSLLIBS="-lssl -lcrypt"
+export MACHTYPE="x86"
+export OSTYPE="linux"
+export OSRELEASE="openembedded"
+
+export CPLUS="${CXX}"
+
+do_compile() {
+ oe_runmake opt
+}