summaryrefslogtreecommitdiff
path: root/packages/pwc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/pwc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/pwc')
-rw-r--r--packages/pwc/pwc-10.0.12-rc1/Makefile.patch19
-rw-r--r--packages/pwc/pwc-10.0.6a/Makefile12
-rw-r--r--packages/pwc/pwc-10.0.6a/endian-fix.patch47
-rw-r--r--packages/pwc/pwc-10.0.7a/Makefile13
-rw-r--r--packages/pwc/pwc-10.0.9-rc1/Makefile13
-rw-r--r--packages/pwc/pwc_10.0.12-rc1.bb35
-rw-r--r--packages/pwc/pwc_10.0.6a.bb30
-rw-r--r--packages/pwc/pwc_10.0.7a.bb29
-rw-r--r--packages/pwc/pwc_10.0.9-rc1.bb29
9 files changed, 0 insertions, 227 deletions
diff --git a/packages/pwc/pwc-10.0.12-rc1/Makefile.patch b/packages/pwc/pwc-10.0.12-rc1/Makefile.patch
deleted file mode 100644
index 8bbe31b0dc..0000000000
--- a/packages/pwc/pwc-10.0.12-rc1/Makefile.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-*** x/Makefile.orig 2006-03-06 08:10:37.000000000 +0100
---- x/Makefile 2006-04-29 11:57:11.000000000 +0200
-***************
-*** 48,54 ****
-
-
- all default:
-! $(MAKE) -C $(KSRC) SUBDIRS=$(PWD) modules
-
- install: default
- install -d $(KMISC)
---- 48,54 ----
-
-
- all default:
-! $(MAKE) -C $(KERNEL_SOURCE) M=$(PWD) modules
-
- install: default
- install -d $(KMISC)
diff --git a/packages/pwc/pwc-10.0.6a/Makefile b/packages/pwc/pwc-10.0.6a/Makefile
deleted file mode 100644
index 8e2334e683..0000000000
--- a/packages/pwc/pwc-10.0.6a/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-ifneq ($(KERNELRELEASE),)
-pwc-objs := pwc-if.o pwc-misc.o pwc-ctrl.o pwc-uncompress.o pwc-dec1.o pwc-dec23.o pwc-kiara.o pwc-timon.o
-
-obj-m += pwc.o
-
-else
-KDIR := /lib/modules/$(shell uname -r)/build
-PWD := $(shell pwd)
-
-default modules:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-endif
diff --git a/packages/pwc/pwc-10.0.6a/endian-fix.patch b/packages/pwc/pwc-10.0.6a/endian-fix.patch
deleted file mode 100644
index 29d689be20..0000000000
--- a/packages/pwc/pwc-10.0.6a/endian-fix.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- pwc-10.0.6a.orig/pwc-if.c 2005-03-31 22:17:29.000000000 +0200
-+++ pwc-10.0.6a/pwc-if.c.new 2005-04-01 09:31:39.099541224 +0200
-@@ -846,7 +846,7 @@
- pdev->vmax_packet_size = -1;
- for (i = 0; i < idesc->desc.bNumEndpoints; i++)
- if ((idesc->endpoint[i].desc.bEndpointAddress & 0xF) == pdev->vendpoint) {
-- pdev->vmax_packet_size = idesc->endpoint[i].desc.wMaxPacketSize;
-+ pdev->vmax_packet_size = le16_to_cpu(idesc->endpoint[i].desc.wMaxPacketSize);
- break;
- }
-
-@@ -1689,9 +1689,14 @@
- int video_nr = -1; /* default: use next available device */
- char serial_number[30], *name;
-
-+ /* added le16_to_cpu to fix big endian issues */
-+ vendor_id = le16_to_cpu(udev->descriptor.idVendor);
-+ product_id = le16_to_cpu(udev->descriptor.idProduct);
-+
- /* Check if we can handle this device */
-+
- Trace(TRACE_PROBE, "probe() called [%04X %04X], if %d\n",
-- udev->descriptor.idVendor, udev->descriptor.idProduct,
-+ vendor_id, product_id,
- intf->altsetting->desc.bInterfaceNumber);
-
- /* the interfaces are probed one by one. We are only interested in the
-@@ -1701,9 +1706,7 @@
- if (intf->altsetting->desc.bInterfaceNumber > 0)
- return -ENODEV;
-
-- vendor_id = udev->descriptor.idVendor;
-- product_id = udev->descriptor.idProduct;
--
-+
- if (vendor_id == 0x0471) {
- switch (product_id) {
- case 0x0302:
-@@ -1954,7 +1957,7 @@
- pdev->vdev->owner = THIS_MODULE;
- video_set_drvdata(pdev->vdev, pdev);
-
-- pdev->release = udev->descriptor.bcdDevice;
-+ pdev->release = le16_to_cpu(udev->descriptor.bcdDevice);
- Trace(TRACE_PROBE, "Release: %04x\n", pdev->release);
-
- /* Now search device_hint[] table for a match, so we can hint a node number. */
diff --git a/packages/pwc/pwc-10.0.7a/Makefile b/packages/pwc/pwc-10.0.7a/Makefile
deleted file mode 100644
index d941f1a6f2..0000000000
--- a/packages/pwc/pwc-10.0.7a/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-ifneq ($(KERNELRELEASE),)
-pwc-objs := pwc-if.o pwc-misc.o pwc-ctrl.o pwc-v4l.o pwc-uncompress.o \
- pwc-dec1.o pwc-dec23.o pwc-kiara.o pwc-timon.o
-
-obj-m += pwc.o
-
-else
-KDIR := /lib/modules/$(shell uname -r)/build
-PWD := $(shell pwd)
-
-default modules:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-endif
diff --git a/packages/pwc/pwc-10.0.9-rc1/Makefile b/packages/pwc/pwc-10.0.9-rc1/Makefile
deleted file mode 100644
index d941f1a6f2..0000000000
--- a/packages/pwc/pwc-10.0.9-rc1/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-ifneq ($(KERNELRELEASE),)
-pwc-objs := pwc-if.o pwc-misc.o pwc-ctrl.o pwc-v4l.o pwc-uncompress.o \
- pwc-dec1.o pwc-dec23.o pwc-kiara.o pwc-timon.o
-
-obj-m += pwc.o
-
-else
-KDIR := /lib/modules/$(shell uname -r)/build
-PWD := $(shell pwd)
-
-default modules:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
-endif
diff --git a/packages/pwc/pwc_10.0.12-rc1.bb b/packages/pwc/pwc_10.0.12-rc1.bb
deleted file mode 100644
index 4292f5c717..0000000000
--- a/packages/pwc/pwc_10.0.12-rc1.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-# FIXME, consider using kernel staging directory instead of KERNEL_SOURCE which is
-# located in the work directory. see module.bbclass
-
-DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
-HOMEPAGE = "http://www.saillard.org/linux/pwc"
-PRIORITY = "optional"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r0"
-
-SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
- file://Makefile.patch;patch=1"
-
-S = "${WORKDIR}/pwc-${PV}"
-
-inherit module
-
-CFLAGS = "'-I${KERNEL_SOURCE}/include' "
-
-CFLAGS_append_arm = " '-D__LINUX_ARM_ARCH__=5' "
-
-CFLAGS_append_armeb = " '-D__LINUX_ARM_ARCH__=5' "
-
-EXTRA_OEMAKE = "'V=1' 'CFLAGS=${CFLAGS}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}' \
- 'KDIR=${STAGING_KERNEL_DIR}'"
-
-export TARGET_LDFLAGS = "-L${STAGING_DIR_TARGET}${layout_libdir} \
- -rpath-link ${STAGING_DIR_TARGET}${layout_libdir}"
-
-do_install() {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
- install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
-}
diff --git a/packages/pwc/pwc_10.0.6a.bb b/packages/pwc/pwc_10.0.6a.bb
deleted file mode 100644
index 26213ee84a..0000000000
--- a/packages/pwc/pwc_10.0.6a.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
-PRIORITY = "optional"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r1"
-
-SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
- file://endian-fix.patch;patch=1 \
- file://Makefile"
-
-S = "${WORKDIR}/pwc-${PV}"
-
-inherit module
-
-do_compile_prepend() {
- cp -f ${WORKDIR}/Makefile ${S}/
-}
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}'
-}
-
-do_install() {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
- install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
-}
-
diff --git a/packages/pwc/pwc_10.0.7a.bb b/packages/pwc/pwc_10.0.7a.bb
deleted file mode 100644
index b3adc80ee5..0000000000
--- a/packages/pwc/pwc_10.0.7a.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
-PRIORITY = "optional"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r0"
-
-SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
- file://Makefile"
-
-S = "${WORKDIR}/pwc-${PV}"
-
-inherit module
-
-do_compile_prepend() {
- cp -f ${WORKDIR}/Makefile ${S}/
-}
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}'
-}
-
-do_install() {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
- install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
-}
-
diff --git a/packages/pwc/pwc_10.0.9-rc1.bb b/packages/pwc/pwc_10.0.9-rc1.bb
deleted file mode 100644
index 6067c0b1aa..0000000000
--- a/packages/pwc/pwc_10.0.9-rc1.bb
+++ /dev/null
@@ -1,29 +0,0 @@
-DESCRIPTION = "Philips USB Webcam driver for Linux that supports VGA resolution"
-PRIORITY = "optional"
-SECTION = "kernel/modules"
-LICENSE = "GPL"
-PR = "r1"
-
-SRC_URI = "http://www.saillard.org/linux/pwc/files/pwc-${PV}.tar.bz2 \
- file://Makefile"
-
-S = "${WORKDIR}/pwc-${PV}"
-
-inherit module
-
-do_compile_prepend() {
- cp -f ${WORKDIR}/Makefile ${S}/
-}
-
-do_compile () {
- unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- oe_runmake 'KDIR=${STAGING_KERNEL_DIR}' \
- 'CC=${KERNEL_CC}' \
- 'LD=${KERNEL_LD}'
-}
-
-do_install() {
- install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
- install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
-}
-