summaryrefslogtreecommitdiff
path: root/packages/pump/pump_0.8.24.bb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-03-26 08:46:59 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-03-26 08:46:59 +0000
commitea94804e9778a03fb3fba0248678b51b8e0ef903 (patch)
tree7216398f6bd2eaccd8c37d96ecd088978f337415 /packages/pump/pump_0.8.24.bb
parente06addd05bcd53f6c010cc5bf708bba1828c9cd2 (diff)
pump_0.8.24.bb: add pump DHCP/BOOTP client
Diffstat (limited to 'packages/pump/pump_0.8.24.bb')
-rw-r--r--packages/pump/pump_0.8.24.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/packages/pump/pump_0.8.24.bb b/packages/pump/pump_0.8.24.bb
new file mode 100644
index 0000000000..0fcbaab709
--- /dev/null
+++ b/packages/pump/pump_0.8.24.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "BOOTP and DHCP client for automatic IP configuration"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "popt"
+
+S = "${WORKDIR}/pump-${PV}"
+
+SRC_URI = "http://ftp.de.debian.org/debian/pool/main/p/pump/pump_0.8.24.orig.tar.gz \
+ file://debian.patch;patch=1"
+
+do_compile() {
+ oe_runmake pump
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 ${S}/pump ${D}${base_sbindir}/pump
+}