summaryrefslogtreecommitdiff
path: root/packages/pulseaudio/pulseaudio-0.9.10
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-06-13 18:48:51 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-06-13 18:48:51 +0000
commit6b969e40156c42692f98157bf26982adb86da18c (patch)
tree540518bf3c088e87f3395d4681ac3a965121de88 /packages/pulseaudio/pulseaudio-0.9.10
parentc2ecee68b3cf7a30ffb34756dbaa888e76a36fe9 (diff)
pulseaudio 0.9.10 add tiny patches from Poky
Diffstat (limited to 'packages/pulseaudio/pulseaudio-0.9.10')
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/2113.diff19
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/2114.diff15
-rw-r--r--packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch48
3 files changed, 82 insertions, 0 deletions
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/2113.diff b/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
new file mode 100644
index 0000000000..666ed34ad3
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/2113.diff
@@ -0,0 +1,19 @@
+from upstream svn r2113
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2112)
++++ configure.ac (wersja 2113)
+@@ -172,6 +172,12 @@
+ AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++old_LIBS=$LIBS
++LIBS="$LIBS $LIBLTDL"
++AC_CHECK_FUNCS([lt_dlmutex_register])
++LIBS=$old_LIBS
++AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
+
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/2114.diff b/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
new file mode 100644
index 0000000000..cbd82eeb84
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/2114.diff
@@ -0,0 +1,15 @@
+from upstream svn r2114
+
+Index: configure.ac
+===================================================================
+--- configure.ac (wersja 2113)
++++ configure.ac (wersja 2114)
+@@ -176,7 +176,7 @@
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+-AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
++AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])
+
+ if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
diff --git a/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
new file mode 100644
index 0000000000..9e9e5f55d3
--- /dev/null
+++ b/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
@@ -0,0 +1,48 @@
+Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4
+
+---
+ configure.ac | 26 +++++++++++++++++++-------
+ 1 file changed, 19 insertions(+), 7 deletions(-)
+
+--- pulseaudio-0.9.10.orig/configure.ac
++++ pulseaudio-0.9.10/configure.ac
+@@ -242,20 +242,32 @@ if test $ret -eq 0 ; then
+ else
+ AC_MSG_RESULT([no])
+ fi
+
+ #### libtool stuff ####
+-
+-AC_LTDL_ENABLE_INSTALL
+-AC_LIBLTDL_INSTALLABLE
+-AC_LIBTOOL_DLOPEN
+-AC_LIBTOOL_WIN32_DLL
++LT_PREREQ([2.2])
++LT_INIT([dlopen win32-dll])
+ AC_PROG_LIBTOOL
+-AC_SUBST(LTDLINCL)
+-AC_SUBST(LIBLTDL)
++#AC_SUBST(LTDLINCL)
++#AC_SUBST(LIBLTDL)
+ AC_CONFIG_SUBDIRS(libltdl)
+
++AC_ARG_WITH(libltdl-libs,
++ [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval)
++if test x$libltdl_libs_prefix != x; then
++ LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl"
++fi
++AC_SUBST(LIBLTDL)
++
++AC_ARG_WITH(libltdl-includes,
++ [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval)
++if test x$libltdl_prefix != x; then
++ LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so"
++fi
++AC_SUBST(LTDLINCL)
++
++
+ old_LIBS=$LIBS
+ LIBS="$LIBS $LIBLTDL"
+ AC_CHECK_FUNCS([lt_dlmutex_register])
+ LIBS=$old_LIBS
+ AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])