summaryrefslogtreecommitdiff
path: root/packages/psplash/psplash_svn.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-03 01:09:38 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-03 01:09:38 +0000
commit3601798980713422b2b45ba39ab1d36a92f9e426 (patch)
tree0ed0e275aee8df313a3493ab5a7f5f45fe8c7774 /packages/psplash/psplash_svn.bb
parent49f14dc848ba6e6928e88a9ae0c020ead296bac2 (diff)
psplash: add OpenMoko branding
Diffstat (limited to 'packages/psplash/psplash_svn.bb')
-rw-r--r--packages/psplash/psplash_svn.bb23
1 files changed, 14 insertions, 9 deletions
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index 668770760f..fe62f64e2c 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -1,26 +1,29 @@
DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
SECTION = "base"
LICENSE = "GPL"
-
PV = "0.0+svn${SRCDATE}"
-PR = "r4"
+PR = "r5"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
-# and rename the resulting .h to pslash-hand-img.h
+# and rename the resulting .h to pslash-hand-img.h (for the logo)
+# respectively psplash-bar-img.h (for the bar).
+# You might also want to patch the colors (see patch)
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
- file://psplash-hand-img.h \
- file://psplash-init"
-
+ file://psplash-hand-img.h \
+ file://psplash-bar-img.h \
+ file://psplash-init "
S = "${WORKDIR}/psplash"
-inherit autotools pkgconfig update-rc.d
+# for now only GTA01, later use openmoko distro override
+SRC_URI_append_fic-gta01 = "file://configurability.patch;patch=1 "
-FILES_${PN} += "/mnt/.psplash"
+inherit autotools pkgconfig update-rc.d
do_configure_append() {
- cp ${WORKDIR}/psplash-hand-img.h ${S}/
+ install -m 0644 ${WORKDIR}/psplash-hand-img.h ${S}/
+ install -m 0644 ${WORKDIR}/psplash-bar-img.h ${S}/
}
do_install_prepend() {
@@ -31,3 +34,5 @@ do_install_prepend() {
INITSCRIPT_NAME = "psplash"
INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
+
+FILES_${PN} += "/mnt/.psplash"