summaryrefslogtreecommitdiff
path: root/packages/psmisc/psmisc-21.8
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-06-28 00:32:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-28 00:32:21 +0000
commitd0b038d42a9b6cc23f98e974ef4b7e4397073dfd (patch)
tree69a539f98bd3cd31e74fda13f975dfa2f278f604 /packages/psmisc/psmisc-21.8
parent6ee41b771288404380e3e3f88828b61328822be6 (diff)
psmisc 21.8: Update for uClibc. psmisc requires libintl on uClibc which it
correctly determines in the configure script but fails to actually use. Patch Makefile.am to link to libintl if it determines that it's required. Has no effect on the glibc build. Also added virtual/libintl to the DEPENDS.
Diffstat (limited to 'packages/psmisc/psmisc-21.8')
-rw-r--r--packages/psmisc/psmisc-21.8/libintl-link.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/psmisc/psmisc-21.8/libintl-link.patch b/packages/psmisc/psmisc-21.8/libintl-link.patch
new file mode 100644
index 0000000000..d9cdd90d71
--- /dev/null
+++ b/packages/psmisc/psmisc-21.8/libintl-link.patch
@@ -0,0 +1,29 @@
+uClibc needs to link against an external libintl but it doesn't do this by
+default. The configure script correctly figures out if this is needed, but
+doesn't actually link to the libraries it decides on. This makes it link to
+them if they are needed:
+
+--- psmisc-22.2/src/Makefile.am 2006/06/28 00:14:07 1.1
++++ psmisc-22.2/src/Makefile.am 2006/06/28 00:14:24
+@@ -5,15 +5,19 @@
+
+ oldfuser_SOURCES = oldfuser.c comm.h signals.c signals.h loop.h i18n.h
+
++oldfuser_LDADD = @INTLLIBS@
++
+ fuser_SOURCES = fuser.c comm.h signals.c signals.h i18n.h fuser.h
+
++fuser_LDADD = @INTLLIBS@
++
+ killall_SOURCES = killall.c comm.h signals.c signals.h i18n.h
+
+-killall_LDADD = @SELINUX_LIB@
++killall_LDADD = @SELINUX_LIB@ @INTLLIBS@
+
+ pstree_SOURCES = pstree.c comm.h i18n.h
+
+-pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
++pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@ @INTLLIBS@
+
+ BUILT_SOURCES = signames.h
+