summaryrefslogtreecommitdiff
path: root/packages/psmisc/files/libintl-link.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-07-03 08:45:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-03 08:45:06 +0000
commit8894f7cfb20ef9fb84217d5bf1dbfd6f9bfec375 (patch)
treedceb32b51b03fe541acdebc41a1cbeda2a9ea8d4 /packages/psmisc/files/libintl-link.patch
parent4e26f686b6c18fe1f57bb20d5edfa81699377ee1 (diff)
parent21dc42547b843538c285d3293ad042425624a61a (diff)
merge of 5672c342d20576efa34f379ef1131d03b578ce6b
and f020c58a9acc8f8db54a7887ff02163ecc5fd3b3
Diffstat (limited to 'packages/psmisc/files/libintl-link.patch')
-rw-r--r--packages/psmisc/files/libintl-link.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/psmisc/files/libintl-link.patch b/packages/psmisc/files/libintl-link.patch
new file mode 100644
index 0000000000..d9cdd90d71
--- /dev/null
+++ b/packages/psmisc/files/libintl-link.patch
@@ -0,0 +1,29 @@
+uClibc needs to link against an external libintl but it doesn't do this by
+default. The configure script correctly figures out if this is needed, but
+doesn't actually link to the libraries it decides on. This makes it link to
+them if they are needed:
+
+--- psmisc-22.2/src/Makefile.am 2006/06/28 00:14:07 1.1
++++ psmisc-22.2/src/Makefile.am 2006/06/28 00:14:24
+@@ -5,15 +5,19 @@
+
+ oldfuser_SOURCES = oldfuser.c comm.h signals.c signals.h loop.h i18n.h
+
++oldfuser_LDADD = @INTLLIBS@
++
+ fuser_SOURCES = fuser.c comm.h signals.c signals.h i18n.h fuser.h
+
++fuser_LDADD = @INTLLIBS@
++
+ killall_SOURCES = killall.c comm.h signals.c signals.h i18n.h
+
+-killall_LDADD = @SELINUX_LIB@
++killall_LDADD = @SELINUX_LIB@ @INTLLIBS@
+
+ pstree_SOURCES = pstree.c comm.h i18n.h
+
+-pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
++pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@ @INTLLIBS@
+
+ BUILT_SOURCES = signames.h
+