summaryrefslogtreecommitdiff
path: root/packages/postfix/postfix_2.0.20.bb
diff options
context:
space:
mode:
authorccsmart <ccsmart@smartpal.de>2005-08-04 17:09:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-04 17:09:08 +0000
commita0d8f8a00a89ea3d89c3939d1c578e218526347d (patch)
tree61a72658564fcc2cebadccf93414daee7b659210 /packages/postfix/postfix_2.0.20.bb
parent712144f4e479ad3764e040b5d9997ce9f37868ef (diff)
Initial out of the box functionality changes.
Diffstat (limited to 'packages/postfix/postfix_2.0.20.bb')
-rw-r--r--packages/postfix/postfix_2.0.20.bb24
1 files changed, 22 insertions, 2 deletions
diff --git a/packages/postfix/postfix_2.0.20.bb b/packages/postfix/postfix_2.0.20.bb
index b9ef1fc2a5..25a030f597 100644
--- a/packages/postfix/postfix_2.0.20.bb
+++ b/packages/postfix/postfix_2.0.20.bb
@@ -1,11 +1,23 @@
SECTION = "console/network"
DEPENDS = "db3 pcre postfix-native"
LICENSE = "IPL"
+PR = "r1"
+
SRC_URI = "ftp://ftp.porcupine.org/mirrors/postfix-release/official/postfix-${PV}.tar.gz \
file://${FILESDIR}/makedefs.patch;patch=1 \
- file://${FILESDIR}/install.patch;patch=1"
+ file://${FILESDIR}/install.patch;patch=1 \
+ file://main.cf_2.0 \
+ file://volatiles \
+ file://postfix \
+ "
+
S = "${WORKDIR}/postfix-${PV}"
+inherit update-rc.d
+
+INITSCRIPT_NAME = "postfix"
+INITSCRIPT_PARAMS = "start 58 3 4 5 . stop 13 0 1 6 ."
+
export SYSLIBS = "-lpcre -ldb -lnsl -lresolv ${LDFLAGS}"
export EXPORT = "AUXLIBS='-lpcre' CCARGS='-DHAS_PCRE ${CFLAGS}' OPT='' DEBUG='-g'"
export CC_append = " -DHAS_PCRE ${CFLAGS}"
@@ -20,9 +32,17 @@ do_compile () {
do_install () {
sh ./postfix-install 'install_root=${D}' -non-interactive
+ mv ${D}${sysconfdir}/postfix/main.cf ${D}${sysconfdir}/postfix/sample-main.cf
+ install -m 644 ${WORKDIR}/main.cf_2.0 ${D}${sysconfdir}/postfix/main.cf
+ install -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/01_postfix
+ install -m 755 ${WORKDIR}/postfix ${D}${sysconfdir}/init.d/postfix
}
pkg_postinst () {
- grep postfix /etc/passwd || adduser --disabled-password --home=/var/spool/mail --ingroup nogroup postfix
+ grep postfix /etc/group || addgroup postfix
+ grep postdrop /etc/group || addgroup postdrop
+ grep vmail /etc/group || addgroup vmail
+ grep postfix /etc/passwd || adduser --disabled-password --home=/var/spool/postfix --ingroup postfix postfix
+ grep vmail /etc/passwd || adduser --disabled-password --home=/var/spool/vmail --ingroup vmail vmail
}