summaryrefslogtreecommitdiff
path: root/packages/popt/popt-native_1.7.bb
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-03-18 07:30:02 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-03-18 07:30:02 +0000
commitf32f481af401630c3221d80b3f01962c93b2f2e2 (patch)
treeef468e6a40501a729b7a5cc625beec81c86c2288 /packages/popt/popt-native_1.7.bb
parent233735a0e08d075e040b3ab21e5bd910b10d346a (diff)
popt: add 1.13, close oebug 4070
* fix native install * fix dependency mangling between target and native * explicitly DEPENDS virtual/libintl * verified the m4.patch and intl.patch in 1.7 has landed upstream in 1.13 * 1.7 is annoyingly slow or even impossible to fetch
Diffstat (limited to 'packages/popt/popt-native_1.7.bb')
-rw-r--r--packages/popt/popt-native_1.7.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/packages/popt/popt-native_1.7.bb b/packages/popt/popt-native_1.7.bb
index 75b90d0763..a83d384eee 100644
--- a/packages/popt/popt-native_1.7.bb
+++ b/packages/popt/popt-native_1.7.bb
@@ -1,5 +1,20 @@
-require popt_${PV}.bb
-inherit native
+require popt.inc
+
+DEPENDS = "gettext-native"
+
+PR = "r5"
+
+inherit native autotools
+
+SRC_URI = "ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/popt-${PV}.tar.gz \
+ file://m4.patch;patch=1 \
+ file://intl.patch;patch=1"
S = "${WORKDIR}/popt-${PV}"
+
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/popt-${PV}"
+
+do_install() {
+ oe_libinstall -a -so libpopt ${STAGING_LIBDIR_NATIVE}
+ install -m 0644 popt.h ${STAGING_INCDIR_NATIVE}
+}