summaryrefslogtreecommitdiff
path: root/packages/pine
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/pine
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/pine')
-rw-r--r--packages/pine/pine_4.64.bb58
1 files changed, 0 insertions, 58 deletions
diff --git a/packages/pine/pine_4.64.bb b/packages/pine/pine_4.64.bb
deleted file mode 100644
index 990e282c3c..0000000000
--- a/packages/pine/pine_4.64.bb
+++ /dev/null
@@ -1,58 +0,0 @@
-DESCRIPTION = "Pine(R) - a Program for Internet News & Email"
-SECTION = "console/network"
-LICENSE = "Pine"
-DEPENDS = "ncurses openssl"
-RDEPENDS_pine = "pico"
-HOMEPAGE = "http://www.washington.edu/pine/"
-
-SRC_URI = "ftp://ftp.cac.washington.edu/pine/pine${PV}.tar.Z"
-S = "${WORKDIR}/pine${PV}"
-
-inherit autotools
-
-#
-# ~lart Pine's build structure...
-#
-PARALLEL_MAKE = ""
-EXTRA_OEMAKE = "-e"
-export MAKE = 'MAKE="make -e" make -e'
-
-CFLAGS += "-I${S}/imap/c-client"
-LDFLAGS += "${S}/imap/c-client/c-client.a -lssl -lcrypt"
-
-export SSLDEFINES = "-DSSL_CERT_DIRECTORY=\\"/etc/ssl/certs\\" -DSSL_KEY_DIRECTORY=\\"/etc/ssl/private\\""
-export SSLCFLAGS = "${CFLAGS} -I${STAGING_INCDIR}/openssl ${SSLDEFINES}"
-export SSLLDFLAGS = "-lssl -lcrypt ${LDFLAGS} -L${STAGING_LIBDIR}/openssl"
-export EXTRALDFLAGS = "${LDFLAGS}"
-
-do_configure() {
- ln -sf ${S}/imap/c-client ${S}/c-client
- cd ${S}/pico/osdep && \
- ${BUILD_CC} -o includer includer.c
- cd ${S}/pine/osdep && \
- ${BUILD_CC} -o includer includer.c
-}
-
-do_compile() {
- unset CFLAGS && unset LDFLAGS
- cd ${S}/imap && oe_runmake slx
-
- for i in pico pine
- do
- cd ${S}/$i && oe_runmake -f makefile.lnx
- done
-}
-
-BINARIES = "imap/mailutil/mailutil imap/mlock/mlock pico/pico pico/pilot pine/pine"
-
-do_install() {
- install -d 0644 ${D}${bindir}
- for binary in ${BINARIES}
- do
- install -m 0755 $binary ${D}${bindir}
- done
-}
-
-PACKAGES = "${PN}-dbg pico pine"
-FILES_pico = "${bindir}/pico ${bindir}/pilot"
-