summaryrefslogtreecommitdiff
path: root/packages/php
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-10-11 04:32:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-10-11 04:32:46 +0000
commit27276da79d08bd88360ecde39db40d60d4ade820 (patch)
treebecbc49bcb23bf95a813fa1eb86c4caf352124c4 /packages/php
parentb129daef2319b67bd58fa9b5dd2da1d12aabd576 (diff)
php: Add version 5.0.5 and 2 patches for it
- the current libxml2 build will not allow PHP5 to compile. --without-schemas has to be removes
Diffstat (limited to 'packages/php')
-rw-r--r--packages/php/php-5.0.5/.mtn2git_empty0
-rw-r--r--packages/php/php-5.0.5/autotools.patch90
-rw-r--r--packages/php/php-5.0.5/endianness.patch10
-rw-r--r--packages/php/php_5.0.5.bb62
4 files changed, 162 insertions, 0 deletions
diff --git a/packages/php/php-5.0.5/.mtn2git_empty b/packages/php/php-5.0.5/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/php/php-5.0.5/.mtn2git_empty
diff --git a/packages/php/php-5.0.5/autotools.patch b/packages/php/php-5.0.5/autotools.patch
new file mode 100644
index 0000000000..7e466a425e
--- /dev/null
+++ b/packages/php/php-5.0.5/autotools.patch
@@ -0,0 +1,90 @@
+diff -Nur php-5.0.5~/acinclude.m4 php-5.0.5/acinclude.m4
+--- php-5.0.5~/acinclude.m4 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/acinclude.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -781,10 +781,10 @@
+ OVERALL_TARGET=[]ifelse($1,,php,$1)
+ php_c_pre='$(CC)'
+ php_c_meta='$(COMMON_FLAGS) $(CFLAGS_CLEAN) $(EXTRA_CFLAGS)'
+- php_c_post=' && echo > $[@]'
++ php_c_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_cxx_pre='$(CXX)'
+ php_cxx_meta='$(COMMON_FLAGS) $(CXXFLAGS_CLEAN) $(EXTRA_CXXFLAGS)'
+- php_cxx_post=' && echo > $[@]'
++ php_cxx_post=' && echo "[#] Generated by PHP badness - GNU libtool" > $[@] && echo "pic_object=none" >> $[@] && echo "non_pic_object=$[@]" | sed -e "s,=.*/,=,; s,\.lo,\.o,g" >> $[@]'
+ php_lo=o
+
+ case $with_pic in
+@@ -1531,6 +1531,7 @@
+
+ dnl even newer glibcs have a different seeker definition...
+
++ AC_CACHE_CHECK([if cookie io functions use off64_t], php_cv_lib_cookie_io_functions_use_off64_t,
+ AC_TRY_RUN([
+ #define _GNU_SOURCE
+ #include <stdio.h>
+@@ -1560,8 +1561,8 @@
+ }
+
+ ],
+- [ cookie_io_functions_use_off64_t=yes ],
+- [ ] )
++ [ php_cv_lib_cookie_io_functions_use_off64_t=yes ],
++ [ php_cv_lib_cookie_io_functions_use_off64_t=no ] ))
+
+ else
+ dnl older glibc versions (up to 2.1.2 ?)
+diff -Nur php-5.0.5~/configure.in php-5.0.5/configure.in
+--- php-5.0.5~/configure.in 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/configure.in 2005-10-10 19:56:55.000000000 -0700
+@@ -247,7 +247,7 @@
+ sinclude(Zend/acinclude.m4)
+ sinclude(Zend/Zend.m4)
+ sinclude(TSRM/tsrm.m4)
+-
++sinclude(TSRM/threads.m4)
+
+
+ divert(2)
+diff -Nur php-5.0.5~/scripts/phpize.m4 php-5.0.5/scripts/phpize.m4
+--- php-5.0.5~/scripts/phpize.m4 2005-10-10 19:56:46.000000000 -0700
++++ php-5.0.5/scripts/phpize.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -1,7 +1,5 @@
+ dnl This file becomes configure.in for self-contained extensions.
+
+-AC_INIT(config.m4)
+-
+ PHP_INIT_BUILD_SYSTEM
+
+ AC_DEFUN([PHP_WITH_PHP_CONFIG],[
+@@ -55,8 +53,6 @@
+ PHP_PROG_RE2C
+ AC_PROG_AWK
+
+-sinclude(config.m4)
+-
+ enable_static=no
+ enable_shared=yes
+
+diff -Nur php-5.0.5~/TSRM/threads.m4 php-5.0.5/TSRM/threads.m4
+--- php-5.0.5~/TSRM/threads.m4 2005-10-10 19:56:40.000000000 -0700
++++ php-5.0.5/TSRM/threads.m4 2005-10-10 19:57:11.000000000 -0700
+@@ -86,7 +86,7 @@
+ pthreads_working=no
+ ], [
+ dnl For cross compiling running this test is of no use. NetWare supports pthreads
+- pthreads_working=no
++ pthreads_working=yes
+ case $host_alias in
+ *netware*)
+ pthreads_working=yes
+diff -Nur php-5.0.5~/TSRM/tsrm.m4 php-5.0.5/TSRM/tsrm.m4
+--- php-5.0.5~/TSRM/tsrm.m4 2005-10-10 19:56:40.000000000 -0700
++++ php-5.0.5/TSRM/tsrm.m4 2005-10-10 19:56:55.000000000 -0700
+@@ -68,7 +68,6 @@
+ ])
+
+ sinclude(threads.m4)
+-sinclude(TSRM/threads.m4)
+
+ AC_DEFUN([TSRM_CHECK_PTHREADS],[
+
diff --git a/packages/php/php-5.0.5/endianness.patch b/packages/php/php-5.0.5/endianness.patch
new file mode 100644
index 0000000000..0231727c33
--- /dev/null
+++ b/packages/php/php-5.0.5/endianness.patch
@@ -0,0 +1,10 @@
+--- php-5.0.5/Zend/zend_strtod.c~ 2005-10-10 19:58:06.000000000 -0700
++++ php-5.0.5/Zend/zend_strtod.c 2005-10-10 20:21:35.000000000 -0700
+@@ -130,6 +130,7 @@
+ * but the word order is big endian.
+ */
+ #define IEEE_BIG_ENDIAN
++#undef IEEE_LITTLE_ENDIAN
+ #endif
+
+ #ifdef __vax__
diff --git a/packages/php/php_5.0.5.bb b/packages/php/php_5.0.5.bb
new file mode 100644
index 0000000000..953f9c08e0
--- /dev/null
+++ b/packages/php/php_5.0.5.bb
@@ -0,0 +1,62 @@
+SECTION = "console/network"
+DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+LICENSE = "PHP"
+DEPENDS = "zlib libxml2 mysql"
+SRC_URI = "http://de3.php.net/distributions/php-${PV}.tar.bz2 \
+ file://autotools.patch;patch=1 \
+ file://endianness.patch;patch=1"
+S = "${WORKDIR}/php-${PV}"
+
+# NOTE: You MUST remove --without-schemas from the libxml2 bb file (and recompile and reinstall it) to compile and use php5
+
+inherit autotools
+
+CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
+EXTRA_OECONF = "--with-cgi --enable-sockets --enable-pcntl \
+ --with-mysql=${STAGING_LIBDIR}/.. \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+ --without-libpng --without-libjpeg \
+ --with-config-file-path=${sysconfdir}/php5 \
+ --cache-file=config.cache \
+ --disable-debug \
+ --disable-rpath \
+ --enable-bcmath \
+ --enable-calendar \
+ --enable-maintainer-zts \
+ --enable-embed=shared \
+ --enable-force-cgi-redirect \
+ --enable-ftp \
+ --enable-inline-optimization \
+ --enable-magic-quotes \
+ --enable-memory-limit \
+ --enable-pic \
+ --enable-safe-mode \
+ --enable-sockets \
+ --enable-track-vars \
+ --enable-trans-sid \
+ --enable-wddx \
+ --sysconfdir=/etc/appWeb \
+ --with-exec-dir=/etc/appWeb/exec \
+ --with-db \
+ --with-regex=system \
+ --with-pear \
+ --with-xml \
+ --with-xmlrpc \
+ --with-zlib \
+ --without-iconv"
+
+EXTRA_OECONF += " --without-pear"
+# Uncomment the following two lines, and comment the above to enable PEAR
+#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR}/php"
+#DEPENDS += " php-native"
+
+acpaths = ""
+
+do_configure_prepend() {
+ find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
+}
+
+do_install () {
+ oe_runmake 'INSTALL_ROOT=${D}' install
+}