summaryrefslogtreecommitdiff
path: root/packages/php/php_5.2.0.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-03-19 08:43:53 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-03-19 08:43:53 +0000
commit567e456cf4ddb785f896102eeb985bf93f71e0e9 (patch)
tree0402f005b5a17adac8befe138c21f757dab37ace /packages/php/php_5.2.0.bb
parent635e2ce5b2939363ff57ab92f7ea8017ad649055 (diff)
packages/php/php_5.2.0.bb : Make-over of the php 5.2.0 package.
It builds PEAR and mysql support by default Provides seperate packages for each php function i.e php-pear, php-cli etc instead of a monolithic (and big) php package. Additional functionality (GD support, other databases) can be enabled easily. Closes bug #1992
Diffstat (limited to 'packages/php/php_5.2.0.bb')
-rw-r--r--packages/php/php_5.2.0.bb75
1 files changed, 60 insertions, 15 deletions
diff --git a/packages/php/php_5.2.0.bb b/packages/php/php_5.2.0.bb
index 3b24fbec40..a4674f08ef 100644
--- a/packages/php/php_5.2.0.bb
+++ b/packages/php/php_5.2.0.bb
@@ -1,12 +1,15 @@
SECTION = "console/network"
DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
LICENSE = "PHP"
-DEPENDS = "zlib libxml2 mysql libiconv"
+DEPENDS = "zlib libxml2 mysql libiconv php-native"
+
SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
+ file://autotools.patch;patch=1 \
+ file://acinclude-xml2-config.patch;patch=1 \
+ file://pear-makefile.patch;patch=1 \
"
-
S = "${WORKDIR}/php-${PV}"
-PR = "r0"
+PR = "r1"
inherit autotools
@@ -14,28 +17,29 @@ export THREADS="pthread"
export LIBS=" -lpthread "
CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
-
EXTRA_OECONF = " --without-iconv \
--enable-discard-path \
--enable-sockets \
--enable-memory-limit \
--enable-wddx \
- --with-zlib"
+ --enable-embedded-mysqli \
+ --enable-magic-quotes \
+ --with-zlib \
+ --with-mysql="${STAGING_DIR}/${TARGET_SYS}" \
+ --with-mysqli="${STAGING_BINDIR_NATIVE}/mysql_config" \
+"
-EXTRA_OECONF += " --without-pear --with-libxml-dir=${STAGING_BINDIR} "
-export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
-# Uncomment the following two lines, and comment the above to enable PEAR
-#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR_NATIVE}/php"
-#DEPENDS += " php-native"
-acpaths = ""
-do_configure () {
- autoreconf
-ac_cv_php_xml2_config_path=${STAGING_BINDIR_CROSS}/xml2-config oe_runconf
-}
+# Uncomment the following two lines, and comment the above to enable PEAR
+EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR} --with-libxml-dir=${STAGING_BINDIR}"
+
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
+export PHP_NATIVE_DIR="${STAGING_BINDIR_NATIVE}"
+export PHP_PEAR_PHP_BIN="/usr/bin/php"
+acpaths = ""
do_configure_append() {
find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
@@ -45,3 +49,44 @@ do_install () {
oe_runmake 'INSTALL_ROOT=${D}' install
}
+
+
+PACKAGES = "${PN}-dbg \
+ ${PN}-cli \
+ ${PN}-pear \
+ ${PN}-dev \
+ ${PN} \
+"
+
+
+FILES_${PN}-dbg ="/usr/bin/.debug"
+
+FILES_${PN}-cli ="/usr/bin/php"
+
+FILES_${PN}-pear ="/usr/bin/pear* /usr/bin/pecl \
+ /usr/lib/php/PEAR \
+ /usr/lib/php/PEAR.php \
+ /usr/lib/php/System.php /usr/lib/php/peclcmd.php /usr/lib/php/pearcmd.php \
+ /usr/lib/php/.channels /usr/lib/php/.channels/.alias \
+ /usr/lib/php/.channels\__uri.reg \
+ /usr/lib/php/.channels\pear.php.net.reg /usr/lib/php/.channels/pecl.php.net.reg \
+ /usr/lib/php/.registry \
+ /usr/lib/php/Archive/Tar.php \
+ /usr/lib/php/Console/Getopt.php /usr/lib/php/OS/Guess.php \
+ /usr/lib/php/.depdb /usr/lib/php/.depdblock /usr/lib/php/.filemap \
+ /usr/lib/php/.lock"
+
+
+FILES_${PN}-dev ="/usr/include/php /usr/include/build \
+ /usr/bin/phpize /usr/bin/php-config"
+
+FILES_${PN} ="/usr/lib/php"
+FILES_${PN} +="/usr/bin"
+
+
+
+RDEPENDS_${PN}-pear =${PN}
+RDEPENDS_${PN}-cli =${PN}
+RDEPENDS_${PN}-dev =${PN}
+
+