summaryrefslogtreecommitdiff
path: root/packages/php/php_5.1.4.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 14:16:37 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-02-20 14:16:37 +0000
commitb592fc2a81a225bdd6e551758c2fca987e7db169 (patch)
tree44f60c62f8c291c430deb260f5fc531b8426cd08 /packages/php/php_5.1.4.bb
parentbc628f97b4d1351d04a963f0e91647b51b26766f (diff)
packages/php/php-5.1.4.bb: Patch to allow php-5 to compile for x86 (at least)
Diffstat (limited to 'packages/php/php_5.1.4.bb')
-rw-r--r--packages/php/php_5.1.4.bb21
1 files changed, 12 insertions, 9 deletions
diff --git a/packages/php/php_5.1.4.bb b/packages/php/php_5.1.4.bb
index 025f112dcd..34d6ea677d 100644
--- a/packages/php/php_5.1.4.bb
+++ b/packages/php/php_5.1.4.bb
@@ -2,10 +2,13 @@ SECTION = "console/network"
DESCRIPTION = "A server-side, HTML-embedded scripting language. This package provides the CGI."
LICENSE = "PHP"
DEPENDS = "zlib libxml2 mysql libiconv"
-SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
- file://autotools.patch;patch=1"
+
+SRC_URI = "http://us2.php.net/distributions/php-${PV}.tar.bz2\
+ file://autotools.patch;patch=1 \
+ file://acinclude-xml2-config.patch;patch=1"
+
S = "${WORKDIR}/php-${PV}"
-PR = "r1"
+PR = "r2"
inherit autotools
@@ -14,13 +17,13 @@ export LIBS=" -lpthread "
CFLAGS += " -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED"
EXTRA_OECONF = "--without-iconv \
- --enable-discard-path \
- --enable-sockets \
- --enable-memory-limit \
- --enable-wddx \
- --with-zlib"
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-memory-limit \
+ --enable-wddx \
+ --with-zlib"
-EXTRA_OECONF += " --without-pear"
+EXTRA_OECONF += " --without-pear --with-libxml-dir=${STAGING_BINDIR} "
# Uncomment the following two lines, and comment the above to enable PEAR
#EXTRA_OECONF += " --with-pear-php-cli=${STAGING_BINDIR_NATIVE}/php"
#DEPENDS += " php-native"