summaryrefslogtreecommitdiff
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-29 09:05:19 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-29 09:05:19 +0000
commita4fb8cb9e3d0de0caa21da16f9644331ccab10c3 (patch)
treef3c0db26cf9444031ccf15831f452fff32df1b84 /packages/perl
parentf0e5f6e2d7e39e5dab9e76cc200804b1948670d3 (diff)
perl: Don't try and patch up references to /usr/include in binary files, as
per #1439, so that configure doesn't fail if you happen to end up with this string in the perl-native binary.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.7.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 2bc2e16a32..1b69cf0e8b 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -53,7 +53,7 @@ do_configure() {
sed -i -e "s%/usr/include/%${STAGING_INCDIR}/%g" config.sh-${TARGET_ARCH}-${TARGET_OS}
#These are strewn all over the source tree
- for foo in `grep -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+ for foo in `grep -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | grep -v "^Binary file .* matches$" | cut -f 1 -d ":"` ; do
echo Fixing: $foo
sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
done