summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-30 14:50:31 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-10-30 14:50:31 +0000
commiteef6f1d950d0772086452937e5cd11e21b303686 (patch)
tree561faf79b12f83c784ad013ad53d01e0d980438b /packages/perl/perl_5.8.8.bb
parenta882f7e95c5db9e7b727cabccbd0773054fea8c7 (diff)
parent18f5c86801714259eaaa1e1a81565984f58ecd14 (diff)
merge of '13924b6ed700ce1a3e3b1fca1d40f3d76389688a'
and 'b93aeec0119f1318d2b0f72f074bfff67bc23942'
Diffstat (limited to 'packages/perl/perl_5.8.8.bb')
-rw-r--r--packages/perl/perl_5.8.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index a3873d99fb..328b4fb5df 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -41,7 +41,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"
# Where to find .so files - use the -native versions not those from the target build
-export PERLHOSTLIB = "${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/"
+export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl/${PV}/"
do_configure() {
# Make hostperl in build directory be the native perl
@@ -138,12 +138,12 @@ do_install() {
}
do_stage() {
install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV} \
+ ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE
# target config, used by cpan.bbclass to extract version information
install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
# target configuration, used by native perl when cross-compiling
- install lib/Config_heavy.pl ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/Config_heavy-target.pl
+ install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# perl shared library headers
for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \