summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-11-10 21:24:04 +0000
committerutx@penguin.cz <utx@penguin.cz>2008-11-11 13:04:23 +0000
commit76e3e6e123c6b2a64905a32e5181e647107e562d (patch)
treedf7eaeae78c8aa3f349fbc8b1b6e5eaec7046ae1 /packages/perl/perl_5.8.8.bb
parente359350395120b910cd281157e678f8416d68416 (diff)
perl and cpan.bbclass: Never reference to host instance of perl:
* install MakeMaker files separately for native and target system * PERL_INC, PERL_LIB and PERL_ARCHLIB changes through environment * for more see http://lists.linuxtogo.org/pipermail/openembedded-devel/2008-November/006815.html
Diffstat (limited to 'packages/perl/perl_5.8.8.bb')
-rw-r--r--packages/perl/perl_5.8.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index 8c00a61536..2118bba68f 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -139,11 +139,15 @@ do_install() {
do_stage() {
install -d ${STAGING_DIR_HOST}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV} \
- ${STAGING_LIBDIR}/perl/${PV}/CORE
+ ${STAGING_LIBDIR}/perl/${PV}/CORE \
+ ${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
install config.sh ${STAGING_DIR_HOST}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
+ # target configuration
+ install lib/Config.pm ${STAGING_LIBDIR}/perl/${PV}/
+ install lib/ExtUtils/typemap ${STAGING_DATADIR}/perl/${PV}/ExtUtils/
# perl shared library headers
for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \