summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-14 03:15:33 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-14 03:15:33 +0000
commit905064886658ec26997e8193c38ea43fc78967c8 (patch)
treecb69b5723ac27bafe5424a64043ea2605cfbe33b /packages/perl/perl_5.8.8.bb
parent8864f65ffecd14e4c6b404594ea484ed7ab9525d (diff)
perl 5.8.8: Directly patch the files that need patching instead of having a
makefile within the perl build apply the patches. This was a left over from the previous perl version and makes modifying these patches a lot more difficult than it really needs to be.
Diffstat (limited to 'packages/perl/perl_5.8.8.bb')
-rw-r--r--packages/perl/perl_5.8.8.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index 603280b423..93b7c8ddd8 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -5,14 +5,15 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r21"
+PR = "r22"
# Major part of version
PVM = "5.8"
SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
file://Makefile.patch;patch=1 \
- file://Makefile.SH.patch \
+ file://Makefile.SH.patch;patch=1 \
+ file://installperl.patch;patch=1 \
file://perl-dynloader.patch;patch=1 \
file://perl-moreconfig.patch;patch=1 \
file://letgcc-find-errno.patch;patch=1 \
@@ -44,9 +45,8 @@ do_configure() {
# Make hostperl in build directory be the native perl
cp -f ${HOSTPERL} hostperl
- # This is silly - should just patch Makefile.SH directly
+ # Do out work in the cross subdir
cd Cross
- cp -f ${WORKDIR}/Makefile.SH.patch .
# Generate configuration
rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
@@ -88,8 +88,6 @@ do_configure() {
rm -f config
echo "ARCH = ${TARGET_ARCH}" > config
echo "OS = ${TARGET_OS}" >> config
-
- oe_runmake patch
}
do_compile() {
if test "${MACHINE}" != "native"; then