summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.7.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-05-31 22:43:44 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 22:43:44 +0000
commit962a5d9c8fdc4e70aa50e63bc9f29e5d439e64b9 (patch)
treeee0daeec41ae874b7f04c300738607839210c920 /packages/perl/perl_5.8.7.bb
parent835efdc055406dbefea949ee55da54db7065cc86 (diff)
perl - Absolute includes fix.
Add config.sh for i486-linux and i586-linux. Disable PARALLEL_MAKE.
Diffstat (limited to 'packages/perl/perl_5.8.7.bb')
-rw-r--r--packages/perl/perl_5.8.7.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/packages/perl/perl_5.8.7.bb b/packages/perl/perl_5.8.7.bb
index 456cc95c84..056fee2676 100644
--- a/packages/perl/perl_5.8.7.bb
+++ b/packages/perl/perl_5.8.7.bb
@@ -4,7 +4,11 @@ include perl.inc
SRC_URI += "file://config.sh-armeb-linux \
file://config.sh-arm-linux \
- file://config.sh-i386-linux"
+ file://config.sh-i386-linux \
+ file://config.sh-i486-linux \
+ file://config.sh-i586-linux"
+
+PARALLEL_MAKE = ""
PR = "r15"
@@ -15,8 +19,10 @@ do_configure() {
rm Makefile.SH.patch
cp ${WORKDIR}/Makefile.SH.patch .
cp ${WORKDIR}/config.sh-mipsel-linux .
- cp ${WORKDIR}/config.sh-i686-linux .
cp ${WORKDIR}/config.sh-i386-linux .
+ cp ${WORKDIR}/config.sh-i486-linux .
+ cp ${WORKDIR}/config.sh-i586-linux .
+ cp ${WORKDIR}/config.sh-i686-linux .
cp ${WORKDIR}/config.sh-armeb-linux .
#perl insists on an extra config.sh for arm EABI
cp config.sh-arm-linux config.sh-arm-linux-gnueabi
@@ -33,6 +39,13 @@ do_configure() {
s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
done
sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
+ sed -i -e "s%/usr/include/%${STAGING_INCDIR}/%g" config.sh-${TARGET_ARCH}-${TARGET_OS}
+
+ #These are strewn all over the source tree
+ for foo in `grep -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
+ echo Fixing: $foo
+ sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
+ done
rm -f config
echo "ARCH = ${TARGET_ARCH}" > config
echo "OS = ${TARGET_OS}" >> config