summaryrefslogtreecommitdiff
path: root/packages/perl/perl_5.8.4.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-05 06:54:17 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-05 06:54:17 +0000
commit6589d01dfe208474892ff4fbb3cb01fb0da603c6 (patch)
treed8badf830fc4ec280cbf4bb5f96a3702556c1670 /packages/perl/perl_5.8.4.bb
parent4ff751b50feb7397a9909f1a684008fa17423223 (diff)
perl: Move the do_configure from perl.inc into perl_5.8.4.bb since it is
only really useful for this version of perl the way it's written.
Diffstat (limited to 'packages/perl/perl_5.8.4.bb')
-rw-r--r--packages/perl/perl_5.8.4.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/perl/perl_5.8.4.bb b/packages/perl/perl_5.8.4.bb
index 085182bb50..10a871c8dd 100644
--- a/packages/perl/perl_5.8.4.bb
+++ b/packages/perl/perl_5.8.4.bb
@@ -5,3 +5,25 @@ PR = "r5"
SRC_URI += "file://uclibc.patch;patch=1 \
file://config.sh-mipsel-linux \
file://config.sh-i686-linux"
+
+do_configure() {
+ ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
+ cp ${HOSTPERL} hostperl
+ cd Cross
+ rm -f Makefile.SH.patch
+ cp ${WORKDIR}/Makefile.SH.patch .
+ cp ${WORKDIR}/config.sh-mipsel-linux .
+ cp ${WORKDIR}/config.sh-i686-linux .
+ cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
+ for i in config.sh-*-linux; do
+ a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
+ newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
+ cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
+ s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
+ done
+ sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
+ rm -f config
+ echo "ARCH = ${TARGET_ARCH}" > config
+ echo "OS = ${TARGET_OS}" >> config
+ oe_runmake patch
+}