summaryrefslogtreecommitdiff
path: root/packages/perl/perl.inc
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-04-01 10:50:27 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-04-01 10:50:27 +0000
commit3cb20b35af93a7b0df80cd0ae87704c73a8c57dc (patch)
treefbbc98c1b5827f23f7f490a6e891603818e95c1a /packages/perl/perl.inc
parent0c26aba1747c6ab2b52020baa8a82c6de095ecb0 (diff)
packages/perl/perl_5.8.7.bb: A set of patches to make perl usable on powerpc targets.
Thanks to Jamie Lenahan for the help
Diffstat (limited to 'packages/perl/perl.inc')
-rw-r--r--packages/perl/perl.inc8
1 files changed, 8 insertions, 0 deletions
diff --git a/packages/perl/perl.inc b/packages/perl/perl.inc
index 4f42d78ded..f063d0e403 100644
--- a/packages/perl/perl.inc
+++ b/packages/perl/perl.inc
@@ -46,6 +46,14 @@ do_compile() {
if test ${TARGET_ARCH} = "sh3" -o ${TARGET_ARCH} = "sh4"; then
OPTIONS="LD=${TARGET_ARCH}-${TARGET_OS}-gcc"
fi
+
+ # You must use gcc to link on powerpc also
+ OPTIONS=""
+ if test ${TARGET_ARCH} = "powerpc" ; then
+ OPTIONS="LD=${TARGET_ARCH}-${TARGET_OS}-gcc"
+ fi
+
+
oe_runmake perl $OPTIONS
}