summaryrefslogtreecommitdiff
path: root/packages/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/perl/perl-native_5.8.8.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/perl/perl-native_5.8.8.bb')
-rw-r--r--packages/perl/perl-native_5.8.8.bb89
1 files changed, 0 insertions, 89 deletions
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
deleted file mode 100644
index e3d73845fc..0000000000
--- a/packages/perl/perl-native_5.8.8.bb
+++ /dev/null
@@ -1,89 +0,0 @@
-DESCRIPTION = "Perl is a popular scripting language."
-HOMEPAGE = "http://www.perl.org/"
-SECTION = "libs"
-LICENSE = "Artistic|GPL"
-DEPENDS = "virtual/db-native gdbm-native"
-PR = "r13"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
-
-SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
- file://perl-5.8.8-gcc-4.2.patch;patch=1 \
- file://Configure-multilib.patch;patch=1 \
- file://perl-configpm-switch.patch;patch=1 \
- file://native-nopacklist.patch;patch=1 \
- file://native-no-gdbminc.patch;patch=1 \
- file://native-perlinc.patch;patch=1 \
- file://makedepend-dash.patch;patch=1 \
- file://asm-pageh-fix.patch;patch=1"
-
-S = "${WORKDIR}/perl-${PV}"
-
-inherit native
-
-do_configure () {
- ./Configure \
- -Dcc="${CC}" \
- -Dcflags="${CFLAGS}" \
- -Dldflags="${LDFLAGS}" \
- -Dcf_by="Open Embedded" \
- -Dprefix=${prefix} \
- -Dvendorprefix=${prefix} \
- -Dvendorprefix=${prefix} \
- -Dsiteprefix=${prefix} \
- \
- -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
- -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
- -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
- -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
- \
- -Duseshrplib \
- -Dusethreads \
- -Duseithreads \
- -Duselargefiles \
- -Ud_dosuid \
- -Ui_db \
- -Ui_ndbm \
- -Ui_gdbm \
- -Di_shadow \
- -Di_syslog \
- -Duseperlio \
- -Dman3ext=3pm \
- -Uafs \
- -Ud_csh \
- -Uusesfio \
- -Uusenm -des
- sed "s!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
- s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!;
- s!^installbin=.*!installbin=\'${STAGING_BINDIR}\'!;
- s!^installsitebin=.*!installsitebin=\'${STAGING_BINDIR}\'!" < config.sh > config.sh.new
- mv config.sh.new config.sh
-}
-do_stage_append() {
- # We need a hostperl link for building perl
- ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
- # Store native config in non-versioned directory
- install -d ${STAGING_DIR_HOST}/perl \
- ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE \
- ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils
- install config.sh ${STAGING_DIR_HOST}/perl
- # target configuration
- install lib/Config.pm ${STAGING_LIBDIR_NATIVE}/perl/${PV}/
- install lib/ExtUtils/typemap ${STAGING_DATADIR_NATIVE}/perl/${PV}/ExtUtils/
- # perl shared library headers
- for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
- uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
- perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
- hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
- cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
- reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
- nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \
- dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
- thread.h warnings.h; do
- install $i ${STAGING_LIBDIR_NATIVE}/perl/${PV}/CORE
- done
-}
-
-PARALLEL_MAKE = ""