summaryrefslogtreecommitdiff
path: root/packages/perl/perl-5.8.8/Makefile.patch
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-21 02:52:14 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-21 02:52:14 +0000
commit9d7a595a810e75c945a6c5da1868c01fb091746a (patch)
tree95cd605515570965fddbc3987f1f87c816556bb6 /packages/perl/perl-5.8.8/Makefile.patch
parentffb2d5eab2ae13cc66f107e6d4988b4075036144 (diff)
perl: Add 5.8.8 and use DEFAULT_PREFERENCE to disable it until more
testing is done. Main differences from the 5.8.7 recipe are: * Always use gcc to link. Same arch's require this, while others can happily use ld. Use gcc for everything. * Fix threading issues by enabling threading in both perl-native and perl. In fact make the configurations almost identical. * No per ARCH configuration, just 32/64/le/be configs. This should stop configurations differing between arch's which made fixing things 5.8.7 difficult. Also means new ARCH's should work without any changes. * Fix up the way miniperl is handled so it shouldn't be the cause of problems for people anymore. * Stop perl-modules depending on perl-dbg, perl-pod, perl-dev etc. * In theory should work for MACHINE="native" now. Only tested for an sh4/glibc target built on an x86_64 host so far. A lot more testing and more cleanups are needed before this is ready to be enabled by default. NOTE: You must build the matching version of perl-native before attempting to build perl (that applies for any version).
Diffstat (limited to 'packages/perl/perl-5.8.8/Makefile.patch')
-rw-r--r--packages/perl/perl-5.8.8/Makefile.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/perl/perl-5.8.8/Makefile.patch b/packages/perl/perl-5.8.8/Makefile.patch
new file mode 100644
index 0000000000..c78a39b178
--- /dev/null
+++ b/packages/perl/perl-5.8.8/Makefile.patch
@@ -0,0 +1,27 @@
+--- perl-5.8.8/Cross/Makefile 2007/04/06 00:47:46 1.1
++++ perl-5.8.8/Cross/Makefile 2007/04/06 00:48:04
+@@ -12,7 +12,7 @@
+
+ export CC = $(CROSS)gcc
+ export CXX = $(CROSS)g++
+-export LD = $(CROSS)ld
++export LD = $(CC)
+ export STRIP = $(CROSS)strip
+ export AR = $(CROSS)ar
+ export RANLIB = $(CROSS)ranlib
+@@ -58,11 +58,11 @@
+ $(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
+ cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
+ cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library
+- cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+- cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
+- cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=/usr/bin/perl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more2 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more3 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
++ cd $(TOPDIR)/.. ; $(MAKE) more4 "PERLRUN=hostperl -I$(TOPDIR)/../fake_config_library -MConfig"
+ cd $(TOPDIR)/.. ; rm -rf install_me_here
+- cd $(TOPDIR)/.. ; make install-strip
++# cd $(TOPDIR)/.. ; make install-strip
+ cd $(TOPDIR)/.. ; sh -x Cross/warp
+
+