summaryrefslogtreecommitdiff
path: root/packages/perl/perl-5.8.8/Makefile.patch
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-14 03:15:33 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-14 03:15:33 +0000
commit905064886658ec26997e8193c38ea43fc78967c8 (patch)
treecb69b5723ac27bafe5424a64043ea2605cfbe33b /packages/perl/perl-5.8.8/Makefile.patch
parent8864f65ffecd14e4c6b404594ea484ed7ab9525d (diff)
perl 5.8.8: Directly patch the files that need patching instead of having a
makefile within the perl build apply the patches. This was a left over from the previous perl version and makes modifying these patches a lot more difficult than it really needs to be.
Diffstat (limited to 'packages/perl/perl-5.8.8/Makefile.patch')
-rw-r--r--packages/perl/perl-5.8.8/Makefile.patch30
1 files changed, 27 insertions, 3 deletions
diff --git a/packages/perl/perl-5.8.8/Makefile.patch b/packages/perl/perl-5.8.8/Makefile.patch
index c78a39b178..cf5cca19a0 100644
--- a/packages/perl/perl-5.8.8/Makefile.patch
+++ b/packages/perl/perl-5.8.8/Makefile.patch
@@ -1,5 +1,7 @@
---- perl-5.8.8/Cross/Makefile 2007/04/06 00:47:46 1.1
-+++ perl-5.8.8/Cross/Makefile 2007/04/06 00:48:04
+Index: perl-5.8.8/Cross/Makefile
+===================================================================
+--- perl-5.8.8.orig/Cross/Makefile 2004-01-13 07:44:01.000000000 +1100
++++ perl-5.8.8/Cross/Makefile 2007-06-14 12:40:44.000000000 +1000
@@ -12,7 +12,7 @@
export CC = $(CROSS)gcc
@@ -9,7 +11,29 @@
export STRIP = $(CROSS)strip
export AR = $(CROSS)ar
export RANLIB = $(CROSS)ranlib
-@@ -58,11 +58,11 @@
+@@ -34,21 +34,6 @@
+ all:
+ @echo Please read the README file before doing anything else.
+
+-gen_patch:
+- diff -Bbur ../Makefile.SH Makefile.SH > Makefile.SH.patch
+- diff -Bbur ../installperl installperl > installperl.patch
+-
+-patch:
+- cd .. ; if [ ! -e ./CROSS_PATCHED ] ; then \
+- patch -p1 < Cross/Makefile.SH.patch; \
+- patch -p1 < Cross/installperl.patch ; mv installperl installperl-patched; \
+- sed -e 's/XXSTRIPXX/$(SYS)/' installperl-patched > installperl; \
+- touch CROSS_PATCHED ; fi
+-
+-dry_patch:
+- cd .. ; patch --dry-run -p1 < Cross/Makefile.SH.patch; \
+- patch --dry-run -p1 < Cross/installperl.patch; \
+-
+ perl:
+ @echo Perl cross-build directory is $(TOPDIR)
+ @echo Target arch is $(SYS)
+@@ -58,11 +43,11 @@
$(TOPDIR)/generate_config_sh config.sh-$(SYS) > $(TOPDIR)/../config.sh
cd $(TOPDIR)/.. ; ./Configure -S ; make depend ; make ; make more
cd $(TOPDIR)/.. ; mkdir -p fake_config_library ; cp lib/Config.pm fake_config_library