summaryrefslogtreecommitdiff
path: root/packages/parted/parted_1.8.7.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-09 08:41:19 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-09 08:41:19 +0000
commit9d829ed05c295df608b4fc108eb1c628fd06fd39 (patch)
treec1b27cfe4498f8abef1a61325922906f3e6a32ff /packages/parted/parted_1.8.7.bb
parent1434b204e16e87b7f59f074f3036d5dcbcf0116f (diff)
parent6ccac10beeaaa02a86081bd6179fd57c208ad6b1 (diff)
merge of '76e1e69496801009ea0aa69c84f76e858978ab99'
and 'db976a98427dd6a195e2cf167e225de2d0206aea'
Diffstat (limited to 'packages/parted/parted_1.8.7.bb')
-rw-r--r--packages/parted/parted_1.8.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
new file mode 100644
index 0000000000..59e3aeaece
--- /dev/null
+++ b/packages/parted/parted_1.8.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "parted, the GNU partition resizing program"
+HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
+LICENSE = "GPLv2"
+SECTION = "console/tools"
+DEPENDS = "readline e2fsprogs-libs"
+PR = "r2"
+
+SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
+ file://syscalls.h \
+ file://syscalls.patch;patch=1 \
+ file://cross-gross-hack.patch;patch=1"
+
+EXTRA_OECONF = "--disable-Werror"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ cp ${WORKDIR}/syscalls.h ${S}/libparted/arch/
+}
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}